Can't save an Alarm

Bug #1236390 reported by Michael Hall on 2013-10-07
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Critical
Renato Araujo Oliveira Filho
qtorganizer5-eds
Fix Committed
Undecided
Unassigned
qtorganizer5-eds (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned

Bug Description

After adding all of the fields for a new alarm, I press the save button but nothing happens.

Related branches

Nekhelesh Ramananthan (nik90) wrote :

This is a bug due to an upstream issue caused by the Evolution Data Server (EDS) which does not seem to be doing its operations properly. However Renato has already fixed it (https://code.launchpad.net/~renatofilho/qtorganizer5-eds/changes-notify/+merge/189487). Just waiting on that to land in the phone image to get this working.

I am however still leaving the bug open since it does affect the clock app.

Changed in ubuntu-clock-app:
milestone: none → final-1.0
importance: Undecided → Critical
status: New → Triaged
Changed in ubuntu-clock-app:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in ubuntu-clock-app:
status: Triaged → In Progress
Nekhelesh Ramananthan (nik90) wrote :

Okay so this has been fixed in the proposed EDS branch. Just waiting it to be uploaded to the next phone image :)

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:qtorganizer5-eds at revision 17, scheduled for release in qtorganizer5-eds, milestone Unknown

Changed in qtorganizer5-eds:
status: New → Fix Committed
Changed in ubuntu-clock-app:
status: In Progress → Fix Committed

I changed the status to "Fix release" by mistake and now I can not change back to "Fix committed"

Changed in qtorganizer5-eds (Ubuntu):
status: New → Fix Released
Daniel Holm (danielholm) wrote :

Yeah, it still does not work in Ubuntu Touch v.1

Ken VanDine (ken-vandine) wrote :

I tested this fix, the clock-app now lets me add and change alarms, but the alarms never get triggered.

Changed in qtorganizer5-eds (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntu-clock-app:
milestone: final-1.0 → backlog
Changed in ubuntu-clock-app:
milestone: backlog → 14.04-month-1
Jeremy Tayco (jtayco) wrote :

Is this app going to update to enable the alarm functionality via the Update Manager app (like most click packages have been) or will it wait until 14.04? I'm just curious as this is the last "critical" function I need out of my phone. Thanks.

Nekhelesh Ramananthan (nik90) wrote :

@Jeremy, I heard that the clock app will be updated via Update manager app as well similar to other click packages. So it should land in 13.10 as well. I am just a bit concerned if EDS (the package it depends on for alarm fixes) will also be updated. But I will verify this with others and let you know.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtorganizer5-eds (Ubuntu Saucy):
status: New → Confirmed
Jeremy Tayco (jtayco) wrote :

@Nekhelesh Thank you for finding out. I really appreciate it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtorganizer5-eds - 0.1.1+14.04.20131024.4-0ubuntu1

---------------
qtorganizer5-eds (0.1.1+14.04.20131024.4-0ubuntu1) trusty; urgency=low

  [ Renato Araujo Oliveira Filho ]
  * Used a proper match all query string. (LP: #1236390)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 17
 -- Ubuntu daily release <email address hidden> Thu, 24 Oct 2013 19:53:51 +0000

Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → Fix Released
Nekhelesh Ramananthan (nik90) wrote :

@Jeremy So after asking around, it seems that the clock app will be regularly updated to Saucy 13.10 and Trusty 14.04. However the dependencies of the clock app such as EDS and the indicator date-time which are required for the proper functioning will most likely be updated only on Trusty 14.04. The reason being that the number of people running saucy on the phone (not desktop) will be low since on the air updates should transition them to Trusty 14.04 anyway. So it would not be worth the effort to backport these fixes to 13.10 (which usually takes time). I would recommend you update to Trusty 14.04 on your phone.

Again this only concerns the phone and not the desktop.

Jeremy Tayco (jtayco) wrote :

@Nekhelesh Thank you for taking the time to resolve this and get back to me! I will certainly update to 14.04 in the next few images (when the installed apps persist through the channel switching). Thank you very much for the help and for helping to develop this app!

Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in qtorganizer5-eds (Ubuntu Saucy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers