Ubuntu CD image build software

Upgrade from 10.04 to 12.04 (LTS -> LTS) using an ISO with no network

Reported by Curtis Jewell on 2012-04-26
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
High
Unassigned
Ubuntu CD Images
High
Unassigned

Bug Description

No other information.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: update-manager 1:0.134.12.1
ProcVersionSignature: Ubuntu 2.6.32-41.88-preempt 2.6.32.59+drm33.24
Uname: Linux 2.6.32-41-preempt x86_64
Architecture: amd64
Date: Thu Apr 26 09:25:35 2012
GConfNonDefault:
 /apps/update-manager/check_new_release_ignore=
 /apps/update-manager/show_details=false
 /apps/update-manager/show_versions=false
InstallationMedia: Ubuntu-Studio 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager
VarLogDistupgradeAptlog:
 Log time: 2012-04-26 09:25:10.615322
 Log time: 2012-04-26 09:25:34.455725
VarLogDistupgradeTermlog:

Curtis Jewell (swordsman) wrote :
Brian Murray (brian-murray) wrote :

Setting up libapt-pkg4.12 (0.8.16~exp12ubuntu6~upgrader1) ...

dpkg: dependency problems prevent configuration of release-upgrader-libapt-pkg-dev:
 release-upgrader-libapt-pkg-dev depends on zlib1g-dev | zlib-dev; however:
  Package zlib1g-dev is not installed.
  Package zlib-dev is not installed.
dpkg: error processing release-upgrader-libapt-pkg-dev (--install):
 dependency problems - leaving unconfigured

Brian Murray (brian-murray) wrote :

Could you add the output of the following command from the disk?

cat /media/cdrom/.disk/info

Thanks in advance.

Changed in update-manager (Ubuntu):
status: New → Incomplete
importance: Undecided → High
summary: - Doing an upgrade from 10.04 to 12.04 (LTS -> LTS) using an ISO
+ Doing an upgrade from 10.04 to 12.04 (LTS -> LTS) using an ISO with no
+ network
summary: - Doing an upgrade from 10.04 to 12.04 (LTS -> LTS) using an ISO with no
- network
+ Upgrade from 10.04 to 12.04 (LTS -> LTS) using an ISO with no network
tags: added: rls-mgr-p-tracking
Brian Murray (brian-murray) wrote :

09:47 <slangasek> so I can confirm that release-upgrader-libapt-pkg-dev is on
                  the alternate CD

Changed in update-manager (Ubuntu):
milestone: none → ubuntu-12.04.1
status: Incomplete → Triaged
Steve Langasek (vorlon) wrote :

Confirmed that release-upgrader-libapt-pkg-dev is in the pool on the alternate CD, when it really shouldn't be. zlib1g-dev apparently isn't on the CD (it has no other reason to be there), which means the upgrade will fail when the network is unavailable.

For 12.04.1 we want to exclude release-upgrader-libapt-pkg-dev from the dist-upgrader pool on the CD, and in the meantime the release notes should advice users to wait for 12.04.1 for networkless 10.04->12.04 CD upgrades.

Changed in update-manager (Ubuntu):
importance: High → Undecided
milestone: ubuntu-12.04.1 → none
Steve Langasek (vorlon) wrote :

needs to be fixed in debian-cd, not in update-manager.

Changed in ubuntu-release-notes:
status: New → Triaged
affects: update-manager (Ubuntu) → ubuntu-cdimage
Changed in ubuntu-cdimage:
importance: Undecided → High
Changed in ubuntu-release-notes:
importance: Undecided → High
Steve Langasek (vorlon) wrote :

debian-cd fixed to pull release-upgrader-python-apt and not release-upgrader-libapt-pkg-dev.

Changed in ubuntu-cdimage:
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

Release note added:
 * Upgrades from Ubuntu 10.04 LTS to 12.04 LTS do not work using the alternate CD or the server CD as a package repository. It is recommended that users running Ubuntu 10.04 LTS wait for the 12.04.1 LTS point release, scheduled for July, before upgrading. (Bug:988941)

Changed in ubuntu-release-notes:
status: Triaged → Fix Released
DEXTER (mydexterid) wrote :

It is not so "Precise" to say wait for the 12.04.1 with the upgrade.
The Precise server upgrade wiki also says:"It is generally recommended that users of Ubuntu 10.04 LTS wait until the first point release, due in July, before upgrading. "
Although it is only true if one would upgrade using the CDs. If the upgrade is done through the network I don't see why should one wait for .1

So please fix the wiki, and the notes, that network upgrade is OK.

It's OK for you to try it, but we aren't going to encourage it because
in our experience the extra testing from early-adopter upgraders before
.1 is important in making sure that upgrades are really solid for
everyone by the time we turn it on by default.

Jan van Emous (jan-vanemous) wrote :

july is nearly gone.
is there a date for the lts 12.04.1 release in the foreseeable future?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers