yakkety in http://old-releases.ubuntu.com/ubuntu is broken

Bug #1751830 reported by LavaVPS on 2018-02-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
William Grant

Bug Description

As all old distribution releases, yakkety was moved to http://old-releases.ubuntu.com/ubuntu
and all other old distribution versions works OK except yakkety.

Simple test fails:

debootstrap --arch=amd64 --variant=minbase --no-check-gpg yakkety out/ubuntu-16.10-x64-mini http://old-releases.ubuntu.com/ubuntu

And we see a lot of missing packages:

...
I: Validating mawk 1.3.3-17ubuntu2
I: Retrieving mount 2.28.2-1ubuntu1
W: Couldn't download package mount (ver 2.28.2-1ubuntu1 arch amd64)
I: Retrieving multiarch-support 2.24-3ubuntu1
I: Validating multiarch-support 2.24-3ubuntu1
...
I: Retrieving tar 1.29b-1
I: Validating tar 1.29b-1
I: Retrieving tzdata 2016g-1
W: Couldn't download package tzdata (ver 2016g-1 arch all)
I: Retrieving ubuntu-keyring 2016.09.19
W: Couldn't download package ubuntu-keyring (ver 2016.09.19 arch all)
I: Retrieving util-linux 2.28.2-1ubuntu1
W: Couldn't download package util-linux (ver 2.28.2-1ubuntu1 arch amd64)
I: Retrieving zlib1g 1:1.2.8.dfsg-2ubuntu5
W: Couldn't download package zlib1g (ver 1:1.2.8.dfsg-2ubuntu5 arch amd64)
E: Couldn't download packages: bsdutils libblkid1 libfdisk1 liblzma5 libmount1 libsmartcols1 libuuid1 mount tzdata ubuntu-keyring util-linux zlib1g

This is not expected.

Yes I know that yakkety is unsported, but all other unsuported distribution versions works flawless from old-realeases.ubuntu.com .

We using this as old image version for internal testing.

https://www.lavavps.lt/ Team

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1751830/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Adam Conrad (adconrad) wrote :

This is a known issue, the removal of yakkety from archive.ubuntu.com was done somewhat overzealously early, leading to us needing to recover the bits from elsewhere, but it's in progress.

affects: ubuntu → ubuntu-cdimage
Changed in ubuntu-cdimage:
assignee: nobody → William Grant (wgrant)
status: New → In Progress
LavaVPS (lavavps) wrote :

We are very interested in this case to be solved

Are there any progress? Or this bug is dropped as related to non-supported Ubuntu version?

---
https://www.lavavps.lt/ Team

Steve Langasek (vorlon) wrote :

This has already been fixed. The indicated bootstrap command succeeds today.

Changed in ubuntu-cdimage:
status: In Progress → Fix Released
LavaVPS (lavavps) wrote :

Hello,

yes, can confirm, that this particular use case for old distribution yakkety is fixed.
But there are still missing packages. Do I need create new bug report or continue/reopen here?

William Grant (wgrant) wrote :

Which packages in particular appear missing?

LavaVPS (lavavps) wrote :

Doing

  apt-get update && apt-get upgrade

Missing 9 of 38 files.

....

Get:36 http://old-releases.ubuntu.com/ubuntu yakkety-updates/main amd64 openssh-sftp-server amd64 1:7.3p1-1ubuntu0.1 [39.7 kB]
Get:37 http://old-releases.ubuntu.com/ubuntu yakkety-updates/main amd64 openssh-server amd64 1:7.3p1-1ubuntu0.1 [341 kB]
Get:38 http://old-releases.ubuntu.com/ubuntu yakkety-updates/main amd64 openssh-client amd64 1:7.3p1-1ubuntu0.1 [594 kB]
Fetched 16.9 MB in 2s (6908 kB/s)
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/bsdutils_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/util-linux_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/mount_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/z/zlib/zlib1g_1.2.8.dfsg-2ubuntu5.1_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/libuuid1_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/libblkid1_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/libmount1_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/libfdisk1_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found
E: Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/libsmartcols1_2.28.2-1ubuntu1.2_amd64.deb 404 Not Found

I guess some other packages are missing. I can check whole yakkety and report all missing files.
Would that be helpful/needed?

Steve Langasek (vorlon) wrote :

Looks like these are all yakkety-updates rather than yakkety-updates release, which may explain why they were missed.

LavaVPS (lavavps) wrote :

It makes OS unusable. And need to know if Ubuntu 16.10 (32/64 bit) is fully dropped and this case will not be solved.

Adam Conrad (adconrad) wrote :

> And need to know if Ubuntu 16.10 (32/64 bit) is fully dropped

Aside from the part where the mirror on old-releases is missing files and needs fixing (it is, and it is, and it will be), the fact that it is *on* old releases means it's end of life, which is how I would read "fully dropped". There's no support for yakkety, you really, really shouldn't be using it, except for some curious academic historical research purposes because you're writing a paper on what the world looked like back in 2016, and if you *are* using it for such a purpose, do be sure to use it behind a very strict firewall.

Manfred Hampl (m-hampl) wrote :

There seems to be an additional issue, reported as https://answers.launchpad.net/ubuntu/+question/669100

Some yakkety-related packages on old-releases.ubuntu.com seem to have wrong protection settings.

An attempt to download http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/fdisk-udeb_2.28.2-1ubuntu1.2_amd64.udeb gives

Forbidden
You don't have permission to access /ubuntu/pool/main/u/util-linux/fdisk-udeb_2.28.2-1ubuntu1.2_amd64.udeb on this server.

LavaVPS (lavavps) on 2018-05-16
Changed in ubuntu-cdimage:
status: Fix Released → Confirmed
William Grant (wgrant) on 2018-05-17
Changed in ubuntu-cdimage:
status: Confirmed → In Progress
Noam Davida (noamda) wrote :

Guys please update, we are stuck with angry customers :-/

William Grant (wgrant) wrote :

This should now be completely fixed.

Note that old-releases is not officially supported -- and if you have customers complaining about it, your customers also probably have unfixed remote root exploits.

Changed in ubuntu-cdimage:
status: In Progress → Fix Released
LavaVPS (lavavps) wrote :

We have tested both 16.10 64bit and 16.10 32bit Yakkety and can confirm the problem is solved.

Thank you guys, great job!

---
Lava VPS Team
https://www.lavavps.lt/en/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers