Lubuntu testcases 'Alternate Install': Debootstrap fails due to dependency problems

Bug #1741713 reported by sudodus on 2018-01-07
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Unassigned

Bug Description

Version: Artful Dot One

ISO Testing

Main output:

"Programmet debootstrap avslutades med ett fel (returvärde 1)." (a red screen)

translated to: "The program debootstrap was finished with an error (return value 1)."

The virtual console #4 indicates:

debootstrap: dpkg: dependency problems prevent configuration of libpython3.6-minimal:amd64
debootstrap: libpython3.6-minimal:amd64 depends on libssl1.0.0 (>=1.0.2~beta3); however:
debootstrap: Package libssl1.0.0 is not installed.

This bug affects both the basic 'Install to the whole disk' and other testcases, for example 'Encryption' and it affects both amd64 and i386 versions.

sudodus (nio-wiklund) on 2018-01-07
description: updated
sudodus (nio-wiklund) on 2018-01-07
description: updated
summary: - Lubuntu amd64 testcase Alternate Install (Entire Disk): Debootstrap
- fails due to dependency problems
+ Lubuntu testcases 'Alternate Install': Debootstrap fails due to
+ dependency problems
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1741713

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debootstrap (Ubuntu):
status: New → Confirmed
Walter Lapchynski (wxl) wrote :

In syslog we find:

Jan 7 19:48:38 debootstrap: dpkg: dependency problems prevent configuration of libpython3.6-minimal:amd64:
Jan 7 19:48:38 debootstrap: libpython3.6-minimal:amd64 depends on libssl1.0.0 (>= 1.0.2~beta3); however:
Jan 7 19:48:38 debootstrap: Package libssl1.0.0 is not installed.
Jan 7 19:48:38 debootstrap:
Jan 7 19:48:38 debootstrap: dpkg: error processing package libpython3.6-minimal:amd64 (--install):
Jan 7 19:48:38 debootstrap: dependency problems - leaving unconfigured
Jan 7 19:48:38 debootstrap: dpkg: dependency problems prevent configuration of python3.6-minimal:
Jan 7 19:48:38 debootstrap: python3.6-minimal depends on libpython3.6-minimal (= 3.6.3-1ubuntu1); however:
Jan 7 19:48:38 debootstrap: Package libpython3.6-minimal:amd64 is not configured yet.
Jan 7 19:48:38 debootstrap:
Jan 7 19:48:38 debootstrap: dpkg: error processing package python3.6-minimal (--install):
Jan 7 19:48:38 debootstrap: dependency problems - leaving unconfigured
Jan 7 19:48:38 debootstrap: dpkg: dependency problems prevent configuration of python3-minimal:
Jan 7 19:48:38 debootstrap: python3-minimal depends on python3.6-minimal (>= 3.6.3-1~); however:
Jan 7 19:48:38 debootstrap: Package python3.6-minimal is not configured yet.
Jan 7 19:48:38 debootstrap:
Jan 7 19:48:38 debootstrap: dpkg: error processing package python3-minimal (--install):
Jan 7 19:48:38 debootstrap: dependency problems - leaving unconfigured
Jan 7 19:48:38 debootstrap: Processing triggers for libc-bin (2.26-0ubuntu2) ...
Jan 7 19:48:38 debootstrap: Errors were encountered while processing:
Jan 7 19:48:38 debootstrap: libpython3.6-minimal:amd64
Jan 7 19:48:38 debootstrap: python3.6-minimal
Jan 7 19:48:38 debootstrap: python3-minimal

Jb (jebsolutions) wrote :

Same problem.

On screen error:

Failure trying to run: chroot /target dpkg --force-overwrite --force-confold --skip-same-version --install /var/cache/apt/archives/libexpat1_2.2.3-1_amd64.deb /var/cache/apt/archives/libpython3.6-minimal_3.6.3-1ubuntu1_amd64.deb /var/cache/apt/archives/python3.6-minimal_3.6.3-1ubuntu1_amd64.deb /var/cache/apt/archives/python3-minimal_3.6.3-0ubuntu2_amd64.deb

further up in /var/log/syslog the same Package libssl1.0.0 is not installed.

Attached full /var/log/syslog

Note: log is from my automated Lubuntu alternate test. Same problem exists with manual Lubuntu Alternate install.

Walter Lapchynski (wxl) on 2018-01-08
Changed in debootstrap (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

This is an issue with the assembly of the CD images; packages that have been SRUed after the 17.10 release are not being correctly included in the package pool on the image.

affects: debootstrap (Ubuntu) → ubuntu-cdimage
Changed in ubuntu-cdimage:
importance: Critical → Undecided
status: Triaged → Confirmed
Steve Langasek (vorlon) wrote :

This issue was caused by the local ftp mirror using stale packages files for artful-security on nusakan, and thus trying to reference older SRU versions that are no longer available in the package pool.

Steve Langasek (vorlon) wrote :

This was a result of me having marked artful in the production branch as not needing its packages files synced because we wouldn't be rolling any more images for it(!). I've cowboyed a change onto nusakan which will cause artful packages files to again be synced, and I am in the process of respinning these images now.

Changed in ubuntu-cdimage:
status: Confirmed → Fix Released
Walter Lapchynski (wxl) wrote :

Confirmed 20180108.1 works on Lubuntu Alternate and Server. Thanks, Steve!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers