arm64 grub needs to load gzio

Bug #1632473 reported by dann frazier on 2016-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Unassigned
debian-installer (Ubuntu)
High
dann frazier
Xenial
High
dann frazier

Bug Description

[Impact]
Ubuntu Server ISO fails to boot on arm64/efi systems.

[Test Case]
Boot the ISO on an arm64 system and select the "Install Ubuntu" option.
Normally you'd expect Linux to boot and the installer screen to be displayed.
However, with this bug, instead you will see:

error: invalid magic number.
unaligned pointer 0xb84630e8
Aborted. Press any key to exit.

This is due to the arm64 kernel now being gzip'd (See LP: #1384955), and GRUB not having loaded the gzio module. Whatever generates the grub.cfg for the cdimages likely needs to be updated to load this module in advance of loading the kernel.

Workaround:
 - At the GRUB menu, press "c" to enter the GRUB shell
 - At the shell, run 'insmod gzio'
 - Press escape to return to the GRUB menu
 - Make your boot selection as per normal.

[Regression Risk]
This is just adding an additional GRUB module to the installer GRUB image. We've been shipping this in installers since 16.10 w/o any reports of issues.

Related branches

dann frazier (dannf) on 2016-10-11
Changed in debian-installer (Ubuntu):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
importance: Undecided → High
dann frazier (dannf) wrote :

xenial will presumably need this change as well to support hwe kernels.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu483

---------------
debian-installer (20101020ubuntu483) yakkety; urgency=medium

  * Tell GRUB to load the gzio module on arm64 now that we're booting
    a compressed kernel (LP: #1632473).

 -- dann frazier <email address hidden> Tue, 11 Oct 2016 16:22:23 -0600

Changed in debian-installer (Ubuntu):
status: In Progress → Fix Released
dann frazier (dannf) on 2017-02-01
Changed in debian-installer (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
importance: Undecided → High
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu451.10

---------------
debian-installer (20101020ubuntu451.10) xenial; urgency=medium

  [ dann frazier ]
  * arm64/xgene-uboot: Set the correct compression flag when generating
    a uImage of a gzip'd kernel. LP: #1384955.
  * Tell GRUB to load the gzio module on arm64 now that we're booting
    a compressed kernel. LP: #1632473.

  [ Adam Conrad ]
  * Add HWE variants for all architectures except powerpc (LP: #1662712)
  * Move master kernels to 4.4.0-62.
  * Rebuild to pick up new components (LP: #1572620, #1558271)

 -- Adam Conrad <email address hidden> Tue, 07 Feb 2017 07:13:40 -0700

Changed in debian-installer (Ubuntu Xenial):
status: In Progress → Fix Released

The verification of the Stable Release Update for debian-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers