"Prepare for OEM install" icon and oem-config-prepare missing on Ubuntu desktop i386

Bug #1572436 reported by Martin Pitt on 2016-04-20
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
High
Unassigned

Bug Description

Image: Xenial Desktop amd64 20160419
Installation: OEM mode, using LVM with encryption

As per http://iso.qa.ubuntu.com/qatracker/milestones/359/builds/117327/testcases/1305/results I should have a "Prepare for shipping to end user" icon on the desktop, but I don't. There's no such link/.desktop file in either /home/oem nor /home/oem/Desktop/.

Worse, there is no "oem-config-prepare" command. The only related package that is installed is oem-config-slideshow-ubuntu, there are no other ubiquity/oem packages. I attach the installer syslog.

Martin Pitt (pitti) wrote :
Changed in ubiquity (Ubuntu Xenial):
importance: Undecided → High
summary: - "Prepare for OEM install" icon missing on desktop
+ "Prepare for OEM install" icon and oem-config-prepare missing on desktop

Indeed the current iso squashfs has ubiquity 2.1.60, but /cdrom/pool/main/u/ubiquity/ has oem-config* 2.21.59.

no longer affects: ubiquity (Ubuntu Xenial)
affects: ubiquity (Ubuntu) → ubuntu-cdimage
Changed in ubuntu-cdimage:
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1572436

tags: added: iso-testing
Martin Pitt (pitti) on 2016-04-20
Changed in ubuntu-cdimage:
status: Confirmed → In Progress
Jason Gerard DeRose (jderose) wrote :

I can confirm that this has been fixed in the 20160420.1 daily amd64 ISO (sha1sum 83a60e1cc28068534b3e4f2f2c9881bb32cbfb74).

Tested OEM installs in both BIOS-mode and UEFI-mode qemu VMs. Seems all good!

Martin Pitt (pitti) wrote :

Thanks for confirming, Jason!

Changed in ubuntu-cdimage:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Still the exact same issue on the current (20160420.1) i386 image -- in pool/, oem-config* is 2.21.59

Changed in ubuntu-cdimage:
status: Fix Released → Confirmed
summary: - "Prepare for OEM install" icon and oem-config-prepare missing on desktop
+ "Prepare for OEM install" icon and oem-config-prepare missing on Ubuntu
+ desktop i386
Martin Pitt (pitti) wrote :

Nevermind, I caught an old image (20160419) due to some image mirroring problem. The current one is good, I verified .disk/info now.

Changed in ubuntu-cdimage:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers