Saucy server installations fail due to dependancy issues on python-newt

Bug #1196981 reported by Para Siva on 2013-07-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Unassigned

Bug Description

Saucy server default installations fail with today's image (20130702) with the following error during 'Select and install software' stage.

Jul 2 12:53:07 in-target: The following packages have unmet dependencies:
Jul 2 12:53:07 in-target: python-newt : Depends: libnewt0.52 (= 0.52.14-11ubuntu7) but 0.52.15-2ubuntu1 is to be installed
Jul 2 12:53:07 in-target: E
Jul 2 12:53:07 in-target: :
Jul 2 12:53:07 in-target: Unable to correct problems, you have held broken packages.
Jul 2 12:53:07 in-target:
Jul 2 12:53:07 in-target: debconf (developer): <-- PROGRESS SET 800
Jul 2 12:53:07 debconf: --> PROGRESS SET 800
Jul 2 12:53:07 in-target: debconf (developer): ----> PROGRESS SET 800
Jul 2 12:53:07 debconf: <-- 0 OK
Jul 2 12:53:07 in-target: debconf (developer): <---- 0 OK
Jul 2 12:53:07 in-target: debconf (developer): --> 0 OK
Jul 2 12:53:07 in-target: tasksel: aptitude failed (100)
Jul 2 12:53:08 debconf: --> GET mirror/protocol
Jul 2 12:53:08 debconf: <-- 0 http
Jul 2 12:53:08 debconf: --> GET mirror/http/proxy
Jul 2 12:53:08 debconf: <-- 0 None
Jul 2 12:53:08 debconf: --> GET debconf/priority
Jul 2 12:53:08 debconf: <-- 0 critical
Jul 2 12:53:08 debconf: --> GET debian-installer/locale
Jul 2 12:53:08 debconf: <-- 0 en_US.UTF-8
Jul 2 12:53:08 debconf: --> PROGRESS INFO pkgsel/progress/cleanup
Jul 2 12:53:08 debconf: <-- 0 OK
Jul 2 12:53:08 debconf: --> PROGRESS STOP
Jul 2 12:53:08 debconf: <-- 0 OK
Jul 2 12:53:08 main-menu[1607]: WARNING **: Configuring 'pkgsel' failed with error code 1
Jul 2 12:53:08 debconf: --> GET debconf/priority
Jul 2 12:53:08 debconf: <-- 0 critical
Jul 2 12:53:08 main-menu[1607]: WARNING **: Menu item 'pkgsel' failed.
Jul 2 12:53:08 debconf: --> SETTITLE debian-installer/pkgsel/title
Jul 2 12:53:08 debconf: <-- 0 OK
Jul 2 12:53:08 debconf: --> CAPB
Jul 2 12:53:08 debconf: <-- 0 multiselect backup progresscancel align escape plugin-terminal plugin-detect-keyboard
Jul 2 12:53:08 debconf: --> METAGET debian-installer/pkgsel/title Description
Jul 2 12:53:08 debconf: <-- 0 Select and install software
Jul 2 12:53:08 debconf: --> SUBST debian-installer/main-menu/item-failure ITEM Select and install software
Jul 2 12:53:08 debconf: Adding [ITEM] -> [Select and install software]
Jul 2 12:53:08 debconf: <-- 0
Jul 2 12:53:08 debconf: --> INPUT critical debian-installer/main-menu/item-failure
Jul 2 12:53:08 debconf: <-- 0 question will be asked
Jul 2 12:53:08 debconf: --> GO

---------------------------------------
This occurs on both amd64 and i386 images of 20130702 during the preseeded installations and also in the manual default server installations. Installer syslog is attached.

Steps to reproduce:
Manual:
1. Start the installation
2. Leave the default selections for language, location, partitioning etc and hit enter in the 'Select and Install software' step.
3. The above error could be seen

Automated:
1. Install utah using the following steps
   sudo apt-add-repository -y ppa:utah/stable
   sudo apt-get update
   sudo apt-get install utah
2. Run the default installation tests using
sudo -u utah -i run_utah_tests.py -i /path/to/saucy-server-amd64.iso -p lp:ubuntu-test-cases/server/preseeds/default.preseed lp:ubuntu-test-cases/server/runlists/default.run -x /etc/utah/bridged-network-vm.xml

Para Siva (psivaa) wrote :
tags: added: iso-testing qa-daily-testing qa-manual-testing rls-s-incoming
Para Siva (psivaa) on 2013-07-02
description: updated
Colin Watson (cjwatson) wrote :

This was squashfs/pool skew (made more probable by the outage on the armhf builder this morning, so there was a relatively long delay between building the squashfs and building the pool). I kicked off a rebuild, 20130702.1, which looks like it should be better.

affects: debian-installer (Ubuntu) → ubuntu-cdimage
Changed in ubuntu-cdimage:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments