'cd' devalias is hardcoded in /install/ofboot.b on PowerPC

Bug #1051313 reported by ojordan on 2012-09-15
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Colin Watson

Bug Description

This has been reported before.... see https://bugs.launchpad.net/ubuntu/+source/yaboot/+bug/74943 and https://bugs.launchpad.net/ubuntu/+source/yaboot/+bug/35731

The file /install/ofboot.b on the PowerPC ISOs contains this line:

boot cd:,\install\yaboot

This stops the ISOs being booted 'normally' from an external CD drive or USB flash drive. It forces you to go through openfirmware.

Changing the line to the more generic

boot &device;:,\\yaboot

would fix the problem.

The same trick can be used to solve a problem with installing to USB drives https://bugs.launchpad.net/ubuntu/+source/yaboot-installer/+bug/956481 (I submitted a simple patch although it could do with somebody who knows what they are doing looking at it).

Thanks for your time

ojordan (ojordan12345) wrote :

Note the use of the \\ which causes openfirmware (as I understand things) to search for a 'blessed' folder.

description: updated
Colin Watson (cjwatson) wrote :

Looks fair to me; we'll give it a go. Thanks!

revno: 1813
fixes bug: https://launchpad.net/bugs/1051313
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Mon 2012-09-24 00:46:19 +0100
message:
  Use more generic yaboot boot location on powerpc (thanks, o jordan).

Changed in ubuntu-cdimage:
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released

The issue is still present on the powerpc 32 and 64 bit mini.iso images found at https://help.ubuntu.com/community/Installation/MinimalCD

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1051313

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers