Some repeating events do not show up

Bug #1546466 reported by Pierre François on 2016-02-17
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Calendar App
High
Renato Araujo Oliveira Filho
qtpim-opensource-src (Ubuntu)
High
Renato Araujo Oliveira Filho
qtpim-opensource-src (Ubuntu RTM)
Undecided
Unassigned

Bug Description

When introducing a new repeating event, it is not shown in the calendar app.
After a sync, it appears in Google calendar online, but it remains still invisible on the phone in Day view, or in some cases invisible in all views.
Sync is also failing to complete after that. A partial sync occurs.
I also noticed another wrong behaviour: since some events remained invisible, I introduced these several times, with the consequence that the webinterface of the Google calendar shows all the instances I introduced. When I delete these events from the calendar online, these events reappear in the calendar online after a sync.

description: updated
description: updated
description: updated

Is this project still alive? No reaction in 6 days???

Set Hallstrom (sakrecoer) wrote :

This happens to me to. I haven't been unable to understand how to reproduce it though, as it sometimes work and sometimes not. Further more, when editing an event that has a yearly repeat, (those few times it DOES appear in calendar), upon saving the edits, it either disappears from the calendar, or is saved with a wrong date.

Set Hallstrom (sakrecoer) wrote :

This could be a duplicate of https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1438910 But that one says there was a commited fix in april last year ( https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1438910/comments/1 ), and i'm running OTA-9.1

The version of Calendar I use is—as far as I know—the last one: 0.4.757, and the systems version is also Ubuntu 15.04 (OTA-9.1).

Bill Filler (bfiller) on 2016-03-07
Changed in ubuntu-calendar-app:
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
status: New → Triaged
tags: added: recurrence
Bill Filler (bfiller) on 2016-03-07
Changed in ubuntu-calendar-app:
milestone: none → 0.5
Changed in qtpim-opensource-src (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Bill Filler (bfiller) on 2016-03-16
Changed in ubuntu-calendar-app:
status: Triaged → In Progress
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtpim-opensource-src 5.0~git20140515~29475884-0ubuntu11.1~overlay6 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu11.1~overlay6) vivid; urgency=medium

  * debian/patches/fix_recurrence_events.patch:
    - Fix issues related to repeating events (LP: #1546466) (LP: #1500192)
      (LP: #1455864) (LP: #1535207) (LP: #1471588) (LP: #1364653)
      (LP: #1473685) (LP: #1447930)

 -- Timo Jyrinki <email address hidden> Thu, 17 Mar 2016 14:17:52 +0000

Changed in qtpim-opensource-src (Ubuntu RTM):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtpim-opensource-src - 5.0~git20140515~29475884-0ubuntu20

---------------
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu20) xenial; urgency=medium

  * debian/patches/fix_recurrence_events.patch:
    - Fix issues related to repeating events (LP: #1546466) (LP: #1500192)
      (LP: #1455864) (LP: #1535207) (LP: #1471588) (LP: #1364653)
      (LP: #1473685) (LP: #1447930)

 -- Timo Jyrinki <email address hidden> Thu, 17 Mar 2016 14:16:49 +0000

Changed in qtpim-opensource-src (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww08-2016
Bill Filler (bfiller) on 2016-03-21
Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers