Agenda page doesn't update immediately if add/remove a daily event

Bug #1535207 reported by TarotChen on 2016-01-18
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Calendar App
High
Renato Araujo Oliveira Filho
qtpim-opensource-src (Ubuntu)
High
Renato Araujo Oliveira Filho
qtpim-opensource-src (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Test Environment:
$ system-image-cli -i
current build number: 232
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-01-18 03:11:49
version version: 232
version ubuntu: 20160116
version device: 20160108-efc96d8
version custom: 20160111-9

Steps:
1.First launch ubuntu-calendar-app
2.Switch to Agenda view from drop-down menu on the left
3.Tap on menu on the right to create a new daily repeating events
4.Check the Agenda view
>It still display empty list with "No upcoming events"
5.Switch to Year view and switch back to Agenda
>New added daily events appears, but still can see "No upcoming events" in the background
6.Tap on a repeating event of a day to edit it and delete the series
7.Check the Agenda view
>It still displays the event list unless user re-launch the ubuntu-calendar-app

Expected result:
Agenda view should refresh immediately if any changes

Bill Filler (bfiller) on 2016-03-07
Changed in ubuntu-calendar-app:
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
status: New → Triaged
tags: added: recurrenc
tags: added: recurrence
removed: recurrenc
Bill Filler (bfiller) on 2016-03-07
Changed in ubuntu-calendar-app:
milestone: none → 0.5
Nekhelesh Ramananthan (nik90) wrote :

@Bill, With renato's branch lp:~renatofilho/ubuntu-calendar-app/optimize which landed in trunk, I am unable to reproduce this issue. It seems fixed. Can you confirm this on your end and then update the bug report?

Changed in ubuntu-calendar-app:
status: Triaged → Incomplete
Changed in qtpim-opensource-src (Ubuntu):
status: New → In Progress
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
importance: Undecided → High
Changed in ubuntu-calendar-app:
status: Incomplete → Confirmed
Bill Filler (bfiller) on 2016-03-10
Changed in ubuntu-calendar-app:
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtpim-opensource-src 5.0~git20140515~29475884-0ubuntu11.1~overlay6 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu11.1~overlay6) vivid; urgency=medium

  * debian/patches/fix_recurrence_events.patch:
    - Fix issues related to repeating events (LP: #1546466) (LP: #1500192)
      (LP: #1455864) (LP: #1535207) (LP: #1471588) (LP: #1364653)
      (LP: #1473685) (LP: #1447930)

 -- Timo Jyrinki <email address hidden> Thu, 17 Mar 2016 14:17:52 +0000

Changed in qtpim-opensource-src (Ubuntu RTM):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtpim-opensource-src - 5.0~git20140515~29475884-0ubuntu20

---------------
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu20) xenial; urgency=medium

  * debian/patches/fix_recurrence_events.patch:
    - Fix issues related to repeating events (LP: #1546466) (LP: #1500192)
      (LP: #1455864) (LP: #1535207) (LP: #1471588) (LP: #1364653)
      (LP: #1473685) (LP: #1447930)

 -- Timo Jyrinki <email address hidden> Thu, 17 Mar 2016 14:16:49 +0000

Changed in qtpim-opensource-src (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww08-2016
Bill Filler (bfiller) on 2016-03-21
Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers