Edit of reminder vaults event time back x hours

Bug #1445577 reported by Allan LeSage on 2015-04-17
84
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Calendar App
High
Renato Araujo Oliveira Filho

Bug Description

Test Case:
1. Install Calendar from store, open
2. Tap mini-burger in top right, select "New Event"
3. Fill in event details for an event to begin at the top of the next hour and save
4. Event appears in week view as beginning at the top of the next hour
5. Tap on event, event details open
6. Edit reminder, e.g. to 5 min. before event and save

Expected behavior:
Event appears in week view as beginning at the top of the next hour

Actual behavior:
Event appears in the week view as beginning five hours plus in the future

Krillin vivid, fresh flash--note that I'm in Chicago UTC-5 .

Related branches

Confirmed. I'm in UTC+1.

It's 12:30, created event for 13:00 which shows up fine.
Edited event to modify reminder, and the event moves in the week view to 12:00.

Seems like an inconsistency between new event and edit event pages causing this?

Changed in ubuntu-calendar-app:
status: New → Confirmed
importance: Undecided → High
themeles (themeles) wrote :

Same behaviour here. But here it appears two hours to early. TZ: UTC+2

Gary.Wang (gary-wzl77) wrote :

Correct start/end datetime was passed from App layer.
Sth goes wrong in QOrganizerEDSEngine::fromIcalTime method in qtorganizer5-eds, bug was caused by a null/invalid QTimeZone.
So when event was updated(name/duration/reminder..etc), issue occurs(event will back x offsetseconds from UTC).
Maybe duplicated bug #1438946

Changed in ubuntu-calendar-app:
assignee: nobody → Gary.Wang (gary-wzl77)
Jonas (jonny-boy) wrote :

I don't know if it's related to this bug, but when swiping down from the clock in the indicator-bar, the time of the event is wrong, if the event was created with the google calendar webapp. The time is right, if you create a event with the ubuntu calendar app. After editing the event with the ubuntu calendar app the time gets wrong in the indicator-bar, too.

Yuri (linux-colombi) wrote :

I swipped down as Jonas: the next events are coming from my Google agenda, but the starting hour use UTC timezone instead of the timezone used on the phone. The display have to use the user defined (phone defined) timezone.

Borim (borim) wrote :

The bug seems only to occur when you do not alter the time when you edit the entry.

1. Create new entry by tapping in the calender app.
2. Edit the entry and set a new time -> the entry is at the correct time.
3. Edit again and do not change the time -> the entry jumps 2 hours back in time (I am at UTC + 2)
After the entry jumped you can edit the entry without jumping again. At least as long as you not change the time.

When you edit the time again, the entry is at the correct time. But if the entry is edited afterwards without modifying the time, the entry jumps 2 hours back in time.

Hendrik (hendrikh) wrote :

This bug is also affecting me.

When i want to edit an appointment, without changing the time, when applied the time of the appointment jumps 2 hours back. (timezone: UTC+2h, Like mentioned above) This occurs only with appointments made in the Ubuntu touch calendar application. Synchronized appointments made somewhere else don't have the problem.

In attachment:
- appointment1: made in Ubuntu touch calendar (screwed up)
- appointment2: made with Thunderbird (handled well)

The difference is DTSTART and DTEND

Changed in ubuntu-calendar-app:
status: Confirmed → In Progress
assignee: Gary.Wang (gary-wzl77) → Renato Araujo Oliveira Filho (renatofilho)
Changed in canonical-devices-system-image:
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww46-2015
status: New → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in ubuntu-calendar-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers