Events saved to birthdays calendar don't appear in timeline

Bug #1347836 reported by Nicholas Skaggs on 2014-07-23
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
High
Kunal Parmar
qtorganizer5-eds (Ubuntu)
Undecided
Renato Araujo Oliveira Filho
Vivid
Undecided
Unassigned

Bug Description

If I create a new event and select the birthday and anniversaries calendar, I cannot see the event in the timeline. This is without syncing any google calendars; merely the default 2 calendars.

The log displays this error when attempting to save:

Fail to create items: Cannot create calendar object: Permission denied

Related branches

description: updated
Mihir Soni (mihirsoni) on 2014-07-24
Changed in ubuntu-calendar-app:
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtorganizer5-eds (Ubuntu):
status: New → Confirmed
Kunal Parmar (pkunal-parmar) wrote :

as it seems, Birthday and Anniversaries calendar is marked as readonly in Evolution, so event can not be save to this calendar and error also suggest the same.

But if we can get this information from EDS that certain calendar is marked as read only then we can show appropriate option in Calendar App

Changed in qtorganizer5-eds (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-calendar-app:
assignee: nobody → Kunal Parmar (pkunal-parmar)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtorganizer5-eds - 0.1.1+15.04.20150508.2-0ubuntu1

---------------
qtorganizer5-eds (0.1.1+15.04.20150508.2-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Renato Araujo Oliveira Filho ]
  * Added a new extra metadata property in collection (read-only
    property). (LP: #1347836)
  * Avoid filter or sort results if not necessary.
  * Implemented support for extended details. (LP: #1426519)
  * Optimize query by filtering collections related with the current
    query.
  * Removed missing debug.
  * Revert wrong commit.
  * Save a trigger for reminders with with secondsBeforeStart equals 0.
    (LP: #1440878)

 -- CI Train Bot <email address hidden> Fri, 08 May 2015 20:01:44 +0000

Changed in qtorganizer5-eds (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtorganizer5-eds (Ubuntu Vivid):
status: New → Confirmed

Fix committed into lp:ubuntu-calendar-app at revision 700, scheduled for release in ubuntu-calendar-app, milestone rtm14

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers