AP test fails on flo, image #22

Bug #1319373 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2014-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
Undecided
Nicholas Skaggs

Bug Description

Testing calendar trunk on flo image #22 before uploading to the store. Here's the full log:-

http://paste.ubuntu.com/7462273/

11:35:01.522 ERROR testresult:46 - FAIL: calendar_app.tests.test_monthview.TestMonthView.test_monthview_go_to_today_prev_year(with touch)
11:35:01.527 ERROR testresult:46 - traceback: {{{
Traceback (most recent call last):
File "/home/phablet/autopilot/calendar_app/tests/test_monthview.py", line 82, in test_monthview_go_to_today_prev_year
self._test_go_to_today(-12)
File "/home/phablet/autopilot/calendar_app/tests/test_monthview.py", line 68, in _test_go_to_today
self.change_month(delta)
File "/home/phablet/autopilot/calendar_app/tests/test_monthview.py", line 46, in change_month
Eventually(NotEquals(old_month)))
File "/usr/lib/python3/dist-packages/testtools/testcase.py", line 406, in assertThat
raise mismatch_error
testtools.matchers._impl.MismatchError: After 10.0 seconds test failed: ==:
reference = datetime.datetime(2014, 5, 14, 0, 0)
actual = datetime.datetime(2014, 5, 14, 0, 0)

Related branches

Changed in ubuntu-calendar-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Nicholas Skaggs (nskaggs) wrote :

It should be noted that these errors occur because the application crashes or otherwise 'white screens' while the test is occurring. It's unclear what is happening, but the test is properly failing -- nothing wrong with the test.

Changed in ubuntu-calendar-app:
status: New → Confirmed

Fix committed into lp:ubuntu-calendar-app at revision 284, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: Confirmed → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers