[calendar] Entry fields can get obscured by OSK

Bug #1311111 reported by Bill Filler on 2014-04-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
High
Kunal Parmar
Ubuntu UX
High
James Mulholland

Bug Description

When creating a new event, clicking in the "Event Name" field will cause the OSK to appear but this will partially obscure the Event Name field.

This field (and all fields in the view) need to scroll into view above the OSK when the OSK is shown. Other apps do this correctly - see the lp:address-book-app for an example of how to do this.

[UX Comment]
Desired behaviour added to Spec (page 12. https://docs.google.com/presentation/d/14NIPecPFKb_8Ad3O4suEGJqVOw9bC4n0s63uWalbZ98/edit#slide=id.g9d53c4a86_3_0)

Related branches

Bill Filler (bfiller) on 2014-04-22
Changed in ubuntu-calendar-app:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-calendar-app:
status: Triaged → In Progress

Fix committed into lp:ubuntu-calendar-app at revision None, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Bill Filler (bfiller) wrote :

This is still an issue now that the word ribbon is on by default. The Event Details field is partially obscured by the word ribbon when creating a new event or editing an existing event.

Changed in ubuntu-calendar-app:
status: Fix Released → Confirmed
Bill Filler (bfiller) wrote :

Just re-tested on rtm image, and the event details field seems to be not obscured on krillin. It is obscured on mako running vivid-proposed image.

However, I think we need a generic fix here. As other fields also get obscured by keyboard. For example:

- Create a new event
- click in location field
- OSK is visible and obscures the field

We should ensure any field that has focus is scrolled into view. There is code in other apps to do this (look at address-book-app or others for an example)

summary: - Event Name field is obscured by OSK
+ entry fields can get obscured by OSK
Changed in ubuntu-calendar-app:
milestone: none → 2015-03-26
Changed in ubuntu-calendar-app:
assignee: Renato Araujo Oliveira Filho (renatofilho) → Kunal Parmar (pkunal-parmar)
status: Confirmed → In Progress

Fix committed into lp:ubuntu-calendar-app at revision 637, scheduled for release in ubuntu-calendar-app, milestone rtm14

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in ubuntu-ux:
assignee: nobody → James Mulholland (jamesjosephmulholland)
importance: Undecided → High
status: New → Fix Committed
description: updated
summary: - entry fields can get obscured by OSK
+ [calendar] entry fields can get obscured by OSK
summary: - [calendar] entry fields can get obscured by OSK
+ [calendar] Entry fields can get obscured by OSK
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers