App stalls when moving between days/weeks

Bug #1301910 reported by Alan Pope 🍺🐧🐱 🦄 on 2014-04-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
Critical
Kunal Parmar

Bug Description

See video attached

When I swipe from one day to the next or one week to the next there's a noticeable delay in movement.

Related branches

Kunal Parmar (pkunal-parmar) wrote :

Can you please provide some details on how many events you have in one day in general.

And Also can you provide snapshot of QML profiler ?

Changed in ubuntu-calendar-app:
importance: Undecided → Critical
Kunal Parmar (pkunal-parmar) wrote :

From video it looks like code is very old, not that latest code might not have issue, but can you try latest code from trunk and run profiler on it.

Kunal Parmar (pkunal-parmar) wrote :

I am able to reproduce issue,
it looks like issue is caused by unnecessary modelChanged signal from EDS.

This should be investigated from EDS side as well.

Kunal Parmar (pkunal-parmar) wrote :

This was causing by model refresh, on model refresh Calendar was using some Sync API which was stalling GUI thread.
Now calendar needs to change way its using Model.

Changed in ubuntu-calendar-app:
assignee: nobody → Kunal Parmar (pkunal-parmar)
Changed in ubuntu-calendar-app:
status: New → In Progress
Kunal Parmar (pkunal-parmar) wrote :

My proposed branch's demo

http://youtu.be/dOXcCuCNTGY

Fix committed into lp:ubuntu-calendar-app at revision 235, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers