Sync'ed calendar events don't appear at the correct time

Bug #1267814 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2014-01-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
Critical
Unassigned
qtorganizer5-eds (Ubuntu)
Undecided
Renato Araujo Oliveira Filho

Bug Description

Enable google calendar sync.:
syncevolution --keyring=no --configure --template Google_Calendar username=<your google email> password=<your gmail password> target-config@gcal calendar
syncevolution --configure --template SyncEvolution_Client syncURL=local://@gcal username= password= google-calendar calendar
syncevolution --sync slow google-calendar

Create some events in your web calendar.
Sync calendars.
Observe that the events don't show up at the correct time in the calendar app.

Perhaps a timezone issue?

Related branches

David Planella (dpm) on 2014-01-22
Changed in ubuntu-calendar-app:
status: New → Triaged
importance: Undecided → High
Kunal Parmar (pkunal-parmar) wrote :

This defect required more information.

What was event timezone and time.
When event was imported what was time and time zone in EDS and in calendar.

And also steps to create such Event.

David Planella (dpm) on 2014-03-12
Changed in ubuntu-calendar-app:
status: Triaged → Incomplete
David Planella (dpm) on 2014-03-21
Changed in ubuntu-calendar-app:
milestone: none → hackdays-1403
Jono Bacon (jonobacon) wrote :

Ths affects me. As an example, today I have the following events scheduled (all Pacific times):

 8am - A
 10am - B
 4pm - C

In my calendar they appear at:

 1am - A
 3am - B
 9am - C

Strangely, a multi-day event appears at 5pm for a short period of time.

Changed in ubuntu-calendar-app:
status: Incomplete → Confirmed
David Planella (dpm) on 2014-03-27
tags: added: bacon-dogfood
Changed in ubuntu-calendar-app:
assignee: nobody → brian larochelle (larochelle-brian)
status: Confirmed → In Progress

An event start date synced down from Google calendar is stored locally like this:
DTSTART;TZID=America/New_York:20140404T171500 - (local time 5:15pm or 17:15, no offset needed)

An event created locally with the calendar app looks like this:
DTSTART:20140404T220000 - (local time 6pm or 18:00, 4 hour offset needs to be applied)

I am GMT-0400.

On my system google synced calendar events are stored here:
.cache/evolution/calendar/$dataSource/calendar.ics
Locally created calendar app events are stored here:
.local/share/evolution/calendar/system/calendar.ics

So it looks like the calendar app (or Qt Organizer - EDS plugin?) is expecting date/time data to be stored in UTC and needs local offset applied.
Google data appears to already be local, but also gets the local offset applied giving incorrect time.

A short term fix in the calendar app would likely require us being able to identify the data's source as google data, and correct the offset.
 - need to confirm google data always comes down in local time, identify other formats.
A long term fix would likely be done in the eds plugin:
https://code.launchpad.net/qtorganizer5-eds

I'd be willing to explore the eds plugin (if that is the correct path), assistance setting up a build/test env would be helpful.
Please advise.

David Planella (dpm) on 2014-04-01
Changed in ubuntu-calendar-app:
importance: High → Critical

As discussed on IRC, the timezone stuff needs implementing in qtorganizer5-eds. While we could potentially do a short term fix in the calendar app to work around the issue, we need it implementing in eds anyway, so would prefer it done there. Do let us know if it's beyond your capabilities to get this in and we'll have to explore other options.

Changed in ubuntu-calendar-app:
assignee: brian larochelle (larochelle-brian) → Renato Araujo Oliveira Filho (renatofilho)
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtorganizer5-eds - 0.1.1+14.04.20140403.1-0ubuntu1

---------------
qtorganizer5-eds (0.1.1+14.04.20140403.1-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Renato Araujo Oliveira Filho ]
  * Initial implementation of time zone support. (LP: #1267814)
 -- Ubuntu daily release <email address hidden> Thu, 03 Apr 2014 21:23:15 +0000

Changed in qtorganizer5-eds (Ubuntu):
status: New → Fix Released

Marking calendar-app project as invalid since this was a bug on eds plugin.

Changed in ubuntu-calendar-app:
status: In Progress → Invalid
Changed in qtorganizer5-eds (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in ubuntu-calendar-app:
assignee: Renato Araujo Oliveira Filho (renatofilho) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers