[reboot] Keyboard doesn't observe haptic settings

Bug #1428606 reported by Alan Pope ๐Ÿบ๐Ÿง๐Ÿฑ ๐Ÿฆ„ on 2015-03-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Calculator App
Medium
Unassigned

Bug Description

In system settings -> language & text, set "Keyboard sound" and "keyboard vibration" on.
In calculator reboot, press numeric buttons.

Expected behaviour:-

* Button presses trigger sounds/vibrations based on settings

Actual behaviour:-

* No haptic feedback or sounds.

Related branches

Changed in ubuntu-calculator-app:
status: New → Triaged
importance: Undecided → Medium
Niklas Wenzel (nikwen) wrote :

This doesn't implement everything you've asked for but at least parts of it: https://code.launchpad.net/~nikwen/ubuntu-calculator-app/reboot-keyboard-buttons-haptic-feedback/+merge/255882

Bartosz Kosiorek (gang65) wrote :

Hi.
Can we close this bug?
The branch lp:~nikwen/ubuntu-calculator-app/reboot-keyboard-buttons-haptic-feedback was already merged.

Changed in ubuntu-calculator-app:
assignee: nobody → Niklas Wenzel (nikwen)
Niklas Wenzel (nikwen) wrote :

I don't think we can close it yet (otherwise I would have done so).

The bug report also asks for key sounds and for adhering to what is selected for haptics and sounds in the settings app. That hasn't been done yet.

Changed in ubuntu-calculator-app:
assignee: Niklas Wenzel (nikwen) → nobody
Bartosz Kosiorek (gang65) wrote :

Vibration for pressing keys on calculator is always on.
It is impossible to disable vibration for calculator

Niklas Wenzel (nikwen) wrote :

Well, it would be possible to disable it (e.g. by putting a MouseArea above the button like it was before vibrations were enabled), but we can definitely not do it based on any settings made in the settings app, so I'd agree to close it now.

Anyone who wants to disable vibration can switch it off globally using the toggle in the settings.

Changed in ubuntu-calculator-app:
status: Triaged → Fix Released
Bartosz Kosiorek (gang65) wrote :

The problem is that I'm unable to disable vibration globally by turn it off in settings.
The vibration is always on.

Could you please take a look at this issue?

Changed in ubuntu-calculator-app:
status: Fix Released → Triaged
assignee: nobody → Niklas Wenzel (nikwen)
Niklas Wenzel (nikwen) wrote :

Oh, yeah, you're right. Just checked it, too. That's probably a toolkit issue. I'll get to this one. ;)

Niklas Wenzel (nikwen) wrote :

Places I found where the toggle does not work:

* AbstractButtons
* (Old) ListItems

I'll file a toolkit issue and try to fix it, but probably not today. ;)

Niklas Wenzel (nikwen) wrote :

I've been looking into this now and tracking my progress using the following bug report: https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1537248

Changed in ubuntu-calculator-app:
status: Triaged → In Progress
Niklas Wenzel (nikwen) wrote :
Niklas Wenzel (nikwen) on 2017-01-10
Changed in ubuntu-calculator-app:
assignee: Niklas Wenzel (nikwen) → nobody
Changed in ubuntu-calculator-app:
status: In Progress → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers