The Ubuntu Boot Speed Project

Avoid spawning notification daemon at startup

Reported by Martin Pitt on 2012-01-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Wishlist
Network Manager Applet
Fix Released
Wishlist
The Sound Menu
Medium
Conor Curran
The Ubuntu Boot Speed Project
Medium
Martin Pitt
indicator-sound (Ubuntu)
Medium
Martin Pitt
nautilus (Ubuntu)
Medium
Martin Pitt
network-manager-applet (Ubuntu)
Medium
Martin Pitt

Bug Description

There is little reason to actually show any notification right at startup. In previous releases we fixed a bunch of programs to avoid starting notify-osd at boot. Now indicator-sound and nautilus are triggering it. Let's avoid it to improve boot speed again.

Martin Pitt (pitti) on 2012-01-05
Changed in indicator-sound (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-boot-speed:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Changed in nautilus (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2012-01-05
Changed in indicator-sound:
status: New → In Progress
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.0.0-0ubuntu2

---------------
indicator-sound (0.8.0.0-0ubuntu2) precise; urgency=low

  * Add lazy_init.patch: Avoid spawning notification daemon right at startup,
    instead initialize it lazily when actually doing a notification. Improves
    boot speed. (LP: #912150)
  * Add disable_Werror.patch: Build without -Werror, to avoid build failure
    due to deprecated declarations. (LP: #912160)
 -- Martin Pitt <email address hidden> Thu, 05 Jan 2012 09:29:36 +0100

Changed in indicator-sound (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-2ubuntu6

---------------
nautilus (1:3.2.1-2ubuntu6) precise; urgency=low

  * Add 19_lazily_initialize_notification_service.patch: Avoid spawning the
    notification daemon at startup through querying server caps.
    Instead, cache the result in server_has_persistence() and initialize it
    lazily. (LP: #912150)
 -- Martin Pitt <email address hidden> Thu, 05 Jan 2012 10:32:29 +0100

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) on 2012-01-05
Changed in ubuntu-boot-speed:
status: Triaged → Fix Released
Changed in nautilus:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Martin Pitt (pitti) wrote :

On my Thinkpad precise now starts without any notify-osd, but on my slow Dell Mini 10 notify-osd is still launched by nm-applet. Using the same wifi, but different drivers. Needs investigation.

Changed in ubuntu-boot-speed:
status: Fix Released → In Progress
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → Triaged
Changed in network-manager-applet:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.1.90-0ubuntu7

---------------
network-manager-applet (0.9.1.90-0ubuntu7) precise; urgency=low

  * Add no_Werror.patch: Disable building with -Werror to avoid build failure
    due to deprecated API with GTK 3.3.x.
  * Add lp912150_lazy_notify_init.patch: Avoid spawning the notification
    daemon at startup through querying server caps. Instead, cache the result
    in applet_notify_server_has_actions() and initialize it lazily.
    (LP: #912150)
  * clear-notification-actions.patch: Unfuzz for above patch.
 -- Martin Pitt <email address hidden> Fri, 06 Jan 2012 12:25:47 +0100

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) on 2012-01-06
Changed in ubuntu-boot-speed:
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2012-01-13
Changed in indicator-sound:
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
milestone: none → 0.8.1.0
Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in nautilus:
status: Confirmed → Fix Released
Conor Curran (cjcurran) on 2012-02-13
Changed in indicator-sound:
status: Fix Committed → Fix Released
Changed in network-manager-applet:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.