OOBE - User takes some photos and sets as wallpaper

Bug #1322074 reported by I Ahmad
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Autopilot Tests
Undecided
Allan LeSage
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned

Bug Description

1. Open the camera app
2. Click the 'shoot' button
3. Open system settings
4. Open the Background page
5. Select Photo/Image
6. Choose a photo
7. Select Pick
8. In the Preview screen select Confirm
9. Confirm that the wallpaper is set

Related branches

Changed in ubuntu-autopilot-tests:
assignee: nobody → Allan LeSage (allanlesage)
I Ahmad (iahmad)
Changed in ubuntu-autopilot-tests:
status: New → In Progress
summary: - User takes some photos and sets as wallpaper
+ OOBE - User takes some photos and sets as wallpaper
Revision history for this message
Allan LeSage (allanlesage) wrote :

Jonas Drange has been working on implementing the new (post-Malta) designs for ubuntu-system-settings and has a good autopilot test working for this; I'll link his branch here and my own branch with some suggested fixes.

Revision history for this message
Allan LeSage (allanlesage) wrote :

I've linked my own branch of suggestions for Jonas here--I see that he's merged it into his own proposed branch.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140723-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140723-0ubuntu1) utopic; urgency=low

  [ jonas-drange ]
  * Hi, this branch seeks to address most of the design changes to the
    Background panel in System Settings (post Malta) The current spec
    and designs are here:
    https://wiki.ubuntu.com/Appearance#Phone.2BAC8-tablet Related bugs:
    https://bugs.launchpad.net/ubuntu/+source/ubuntu-system-
    settings/+bug/1297418 https://bugs.launchpad.net/ubuntu-autopilot-
    tests/+bug/1322074 Changes: Removed all functionality and code
    related to changing scope background. Added autopilot tests. New
    header design that collapses/expands. Not part of this branch:
    Scaling in preview has not been implemented. It should have its own
    branch. After rotating the phone in system settings, the default
    background will appear to have been deselected. This is because the
    current background is now the default tablet background. Confirmed
    on mako. Will file bug. Thank you. (LP: #1322074)

  [ Iain Lane ]
  * Add 1 gu of spacing between rows in the main screen's grid

  [ Pawel Stolowski ]
  * Added X-Ubuntu-Default-Department-ID key to the desktop file. This
    is required by click scope to support departments for preinstalled
    applications.
 -- Ubuntu daily release <email address hidden> Wed, 23 Jul 2014 00:45:42 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints