copy-package's -c option does not work

Bug #247602 reported by Martin Pitt on 2008-07-11
Affects Status Importance Assigned to Milestone

Bug Description

I want to copy a source package from a PPA to intrepid multiverse (the package already exists there):

   nvidia-graphics-drivers-173 | 173.14.09-0ubuntu4 | intrepid/multiverse | source

$ -p lrm-intrepid -c multiverse nvidia-graphics-drivers-173
2008-07-11 14:19:23 INFO creating lockfile
2008-07-11 14:19:27 INFO FROM: lrm-intrepid: intrepid-RELEASE
2008-07-11 14:19:27 INFO TO: Primary Archive for Ubuntu: intrepid-RELEASE
2008-07-11 14:19:27 ERROR nvidia-graphics-drivers-173 173.14.09-0ubuntu5 in intrepid was skipped because it is not in MULTIVERSE component

It seems that -c specifies the component of the *source*, not the *target*. That doesn't seem to make sense to me, we already know the source component, but we want to specify the target one. If I leave out -c, it will be put into main, so that we have it in two components. I can it, of course, but the initial builds will always fail to upload, since they still want to go to main.

Making this operation possible would ease this kind of sponsoring a lot. Thank you!

Celso Providelo (cprov) on 2009-07-20
Changed in soyuz:
importance: Undecided → Medium
status: New → Triaged
Changed in launchpad:
importance: Medium → Low
Colin Watson (cjwatson) wrote : is now in ubuntu-archive-tools, as copy-package. Reassigning and retitling bug.

affects: launchpad → ubuntu-archive-tools
summary: -'s -c option does not work
+ copy-package's -c option does not work
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers