snaps using u-a-p fail to start, could not find Qt platform plugin for mir

Bug #1674739 reported by Pat McGowan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu App Platform
Critical
Timo Jyrinki

Bug Description

Zesty using Unity8 classic
Launch any app, it fails with

"This application failed to start because it could not find or load the Qt platform plugin "ubuntumirclient" in "".

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

All the apps need to plug mir-libs now to work on the --edge versions of u-a-p and mir
Would be nice to get a better error, not sure if that is possible.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

We need to add the QPA back into u-a-p. We only wanted to remove the mir client libraries.

Changed in ubuntu-app-platform:
assignee: nobody → Timo Jyrinki (timo-jyrinki)
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :
Changed in ubuntu-app-platform:
status: Confirmed → Fix Committed
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

works in edge channel

Changed in ubuntu-app-platform:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers