libgcc_s.so.1 not found by app using ubuntu-app-platform content snap

Bug #1642900 reported by Olivier Tilloy
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu App Platform
Undecided
Timo Jyrinki

Bug Description

I have updated the webbrowser-app snap to make use of the ubuntu-app-platform content snap (prior to this, it bundled all its dependencies, including Qt and oxide).

After connecting the "webbrowser-app:platform" plug to the "ubuntu-app-platform:platform" slot, the app launches and works well, but I’m seeing the following error message at application shutdown:

  libgcc_s.so.1 must be installed for pthread_cancel to work

I have ubuntu-core version 16.04.1 installed, and the lib is there: /snap/ubuntu-core/423/lib/x86_64-linux-gnu/libgcc_s.so.1.

I’ve verified that reverting to the webbrowser-app snap that bundles all its deps makes the error go away, so I’m wondering whether that could be a limitation/issue with how content sharing is handled in snappy?

affects: snappy → ubuntu-app-platform
Revision history for this message
dinamic (dinamic6661) wrote :

i also see this in terminal app

Changed in ubuntu-app-platform:
status: New → In Progress
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :
Changed in ubuntu-app-platform:
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

The platform snap change is still only in the edge channel, but testable from there. The pull request comment indicates it could be fixed with a refactoring there, although not confirmed.

Changed in ubuntu-app-platform:
status: In Progress → Fix Committed
Revision history for this message
Olivier Tilloy (osomon) wrote :

I confirm that the error message is no longer to be seen at shutdown, thanks!

Changed in ubuntu-app-platform:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers