[regression] Webbrowser tries to open file:///usr/share/webbrowser-app/'URL' instead of the URL directly

Bug #1253703 reported by Ursula Junque on 2013-11-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Application Launcher
Fix Released
Critical
Ted Gould
upstart-app-launch (Ubuntu)
Undecided
Unassigned

Bug Description

I notice this one while using Facebook webapp. It starts working fine, when I click on a link it opens the webbrowser as it should, but after a while when I click the link it goes to the webbbrowser window and fails trying to open "file:///usr/share/webbrowser-app/'URL'" instead.

Steps to reproduce:
1) adb shell; su - phablet;
2) upstart-app-launch webbrowser-app http://www.ubuntu.com
Browser should open trying to load www.ubuntu.com.
3) Run the same command again.
Browser will open displaying error message:
"Network Error
It appears you are having trouble viewing: file:///usr/share/webbrowser-app/'http://www.ubuntu.com'.
Ubuntu suggests you check your network settings and try refreshing the page."

Currently using r27 with channel devel-proposed, read-only, in a Nexus 4. This problem wasn't happening with only devel (r10).

Related branches

Adnane Belmadiaf (daker) on 2013-11-21
Changed in webbrowser-app:
status: New → Confirmed
Ursula Junque (ursinha) on 2013-11-21
description: updated

Confirmed it happens on image 27 but not image 10.

Ursula Junque (ursinha) on 2013-11-22
tags: added: avengers regression
Olivier Tilloy (osomon) wrote :

It appears that the URLs are now being passed to the application with surrounding single quotes, i.e. "'http://ubuntu.com'" instead of "http://ubuntu.com". I’ll dig to understand whether that’s a regression in the URL handler service, or if the application is supposed to trim those extra single quotes.

Ted Gould (ted) wrote :

Seems this the case of a single URL, we don't run it through the shell unescaping. Tested all the hard cases :-)

affects: webbrowser-app → upstart-app-launch
Ted Gould (ted) on 2013-11-22
Changed in upstart-app-launch:
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Ricardo Salveti (rsalveti) wrote :

Critical as it's a regression.

summary: - Webbrowser tries to open file:///usr/share/webbrowser-app/'URL' instead
- of the URL directly
+ [regression] Webbrowser tries to open file:///usr/share/webbrowser-
+ app/'URL' instead of the URL directly
Changed in upstart-app-launch:
importance: High → Critical
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:upstart-app-launch at revision 86, scheduled for release in upstart-app-launch, milestone Unknown

Changed in upstart-app-launch:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart-app-launch - 0.3+14.04.20131126-0ubuntu1

---------------
upstart-app-launch (0.3+14.04.20131126-0ubuntu1) trusty; urgency=low

  [ Ted Gould ]
  * Bumping to 0.3 to reflect that we added a new env var to the library
    which is needed for testing URL Dispatcher
  * Reenable ZG and port to libzg-2.0. (LP: #1197569)
  * Ensure quoted single URIs passed to a %U are unquoted. (LP:
    #1253703)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 86
 -- Ubuntu daily release <email address hidden> Tue, 26 Nov 2013 02:07:13 +0000

Changed in upstart-app-launch (Ubuntu):
status: New → Fix Released
Ursula Junque (ursinha) on 2013-11-26
tags: added: r27
Ursula Junque (ursinha) wrote :

I'm using r34 and the bug is still here. I am able to reproduce with the same steps in bug description.

Changed in upstart-app-launch (Ubuntu):
status: Fix Released → New
Oliver Grawert (ogra) wrote :

Works fine for me on r31 if i put the URL in quotes ...

Didier Roche (didrocks) wrote :

I think we need someone from the upstart-app-launch team to look at it

Changed in upstart-app-launch:
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart-app-launch (Ubuntu):
status: New → Confirmed
Tiago Salem Herrmann (tiagosh) wrote :

We are having similar problems on messaging-app and dialer-app receiving quoted urls and consequently QUrl is unable to parse them.
I suppose the code that is adding the quotes is this:
http://bazaar.launchpad.net/~indicator-applet-developers/upstart-app-launch/trunk.14.04/view/head:/libupstart-app-launch/upstart-app-launch.c#L96

Ted Gould (ted) wrote :

Could you add what the apps are getting as parameters and what their Exec line is. Thanks!

Ted Gould (ted) wrote :

Ah, I see now. Fixed a different bug. So this is a second activation bug.

Tiago Salem Herrmann (tiagosh) wrote :

Reading from command line is fine, the problem only happens when apps receive url's from the UriHandler qml component.
Those are quoted.

the exec line is: messaging-app message:///12345

Ted Gould (ted) on 2013-12-05
Changed in upstart-app-launch:
status: Confirmed → In Progress
Charles Kerr (charlesk) wrote :

Confirmed that lp:~ted/upstart-app-launch/second-exec-quotes works for me on the phone:

running "upstart-app-launch webbrowser-app http://www.ubuntu.com" twice from the command line as per the problem statement now works.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:upstart-app-launch at revision 88, scheduled for release in upstart-app-launch, milestone Unknown

Changed in upstart-app-launch:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart-app-launch - 0.3+14.04.20131209-0ubuntu2

---------------
upstart-app-launch (0.3+14.04.20131209-0ubuntu2) trusty; urgency=low

  * Restrict on which arch we build url-dispatcher due to the ust build-dep
 -- Didier Roche <email address hidden> Mon, 09 Dec 2013 13:47:51 +0100

Changed in upstart-app-launch (Ubuntu):
status: Confirmed → Fix Released
Ted Gould (ted) on 2014-04-16
Changed in upstart-app-launch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers