Ubuntu Accomplishments - unmet dependencies on 13.04 / 13.10

Bug #1177740 reported by Peter Ahlgren on 2013-05-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Accomplishments System
Critical
Unassigned

Bug Description

Trying to install Ubuntu Accomplishments according to the instructions on the Accomplishments Wiki-page. But the packages from the PPA fail to install with the following error message:

The following packages have unmet dependencies:
 accomplishments-daemon : Depends: ubuntuone-couch but it is not installable
 accomplishments-viewer : Depends: gir1.2-launchpad-integration-3.0 but it is not installable
E: Unable to correct problems, you have held broken packages.

Matt Fischer (mfisch) wrote :

I'm using it in 13.04 just fine. Can you post the output from apt-get update?

Matt Fischer (mfisch) wrote :

I think we haven't done a release yet for raring. You should switch to the daily PPA.

sudo add-apt-repository ppa:ubuntu-accomplishments/daily
sudo add-apt-repository -r ppa:ubuntu-accomplishments/releases
sudo apt-get update

$ sudo add-apt-repository ppa:ubuntu-accomplishments/daily
Cannot access PPA (https://launchpad.net/api/1.0/~ubuntu-accomplishments/+archive/daily) to get PPA information, please check your internet connection.

Matt Fischer (mfisch) wrote :

I just pushed releases for raring and saucy. The daily is in good shape and I prefer to use it, but after 0.4 goes out the daily will be crazy for a bit. Try an apt-get update and an install in about an hour so the builders have some time.

Valerie:

Sorry I had a typo in what I told you: ppa:ubuntu-accomplishments-admins/daily

Changed in ubuntu-accomplishments-system:
status: New → Fix Committed
assignee: nobody → Matthew Fischer (mfisch)
importance: Undecided → Critical
Matt Fischer (mfisch) wrote :

Actually I see that the builders need 8 hours, they're busy, so please try tomorrow.

Peter Ahlgren (peter.ahlgren) wrote :

I think its working better, but now I get:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 accomplishments-viewer : Depends: gir1.2-launchpad-integration-3.0 but it is not installable
E: Unable to correct problems, you have held broken packages.

Matt Fischer (mfisch) wrote :

I'll ask seb about this tomorrow.

Matt Fischer (mfisch) wrote :

Peter, do you mind retitling this bug with that info? I talked to seb and that package is no longer maintained, so code changes are needed.

Peter Ahlgren (peter.ahlgren) wrote :

Retitling it to "Ubuntu Accomplishments - unmet dependencies" ?

Matt Fischer (mfisch) wrote :

Yep.

summary: - Cant install on 13.04. Failed to fetch the PPA.
+ Ubuntu Accomplishments - unmet dependencies on 13.04
Matt Fischer (mfisch) on 2013-06-17
Changed in ubuntu-accomplishments-system:
status: Fix Committed → Triaged
assignee: Matthew Fischer (mfisch) → nobody
d❤vid (kwill) wrote :

Similar issue on 13.10 installing from ppa:ubuntu-accomplishments/releases (see duplicate https://bugs.launchpad.net/ubuntu-accomplishments-system/+bug/1260256 for details) ...

The following packages have unmet dependencies:
 accomplishments-daemon : Depends: ubuntuone-couch but it is not installable
 accomplishments-viewer : Depends: gir1.2-launchpad-integration-3.0 but it is not installable
E: Unable to correct problems, you have held broken packages.

summary: - Ubuntu Accomplishments - unmet dependencies on 13.04
+ Ubuntu Accomplishments - unmet dependencies on 13.04 / 13.10
d❤vid (kwill) wrote :

Same error on 13.10 installing from ppa:ubuntu-accomplishments-admins/daily ...

The following packages have unmet dependencies:
 accomplishments-daemon : Depends: ubuntuone-couch but it is not installable
 accomplishments-viewer : Depends: gir1.2-launchpad-integration-3.0 but it is not installable
E: Unable to correct problems, you have held broken packages.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers