Ubuntu Accomplishments Daemon

Daemon fails to start because "No option 'langdefault' in section 'general'

Reported by Chris Wayne on 2012-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Accomplishments Daemon
Undecided
Unassigned

Bug Description

Release: 0.1

Summary:

When starting the GUI, the daemon fails to start. The following stack trace is shown:

Daemon seems to be installed to: /usr
Unhandled Error
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/twisted/application/app.py", line 652, in run
    runApp(config)
  File "/usr/lib/python2.7/dist-packages/twisted/scripts/twistd.py", line 23, in runApp
    _SomeApplicationRunner(config).run()
  File "/usr/lib/python2.7/dist-packages/twisted/application/app.py", line 386, in run
    self.application = self.createOrGetApplication()
  File "/usr/lib/python2.7/dist-packages/twisted/application/app.py", line 451, in createOrGetApplication
    application = getApplication(self.config, passphrase)
--- <exception caught here> ---
  File "/usr/lib/python2.7/dist-packages/twisted/application/app.py", line 462, in getApplication
    application = service.loadApplication(filename, style, passphrase)
  File "/usr/lib/python2.7/dist-packages/twisted/application/service.py", line 405, in loadApplication
    application = sob.loadValueFromFile(filename, 'application', passphrase)
  File "/usr/lib/python2.7/dist-packages/twisted/persisted/sob.py", line 210, in loadValueFromFile
    exec fileObj in d, d
  File "/usr/bin/accomplishments-daemon", line 47, in <module>
    gpg_key=os.path.join(paths.systemdata_dir, "validation-key.pub"))
  File "/usr/lib/python2.7/dist-packages/accomplishments/daemon/app.py", line 41, in applicationFactory
    show_notifications=True)
  File "/usr/lib/python2.7/dist-packages/accomplishments/daemon/dbusapi.py", line 69, in __init__
    self.api = api.Accomplishments(self, self.show_notifications)
  File "/usr/lib/python2.7/dist-packages/accomplishments/daemon/api.py", line 418, in __init__
    self._create_all_trophy_icons()
  File "/usr/lib/python2.7/dist-packages/accomplishments/daemon/api.py", line 603, in _create_all_trophy_icons
    files = self._get_accomplishments_files_list()
  File "/usr/lib/python2.7/dist-packages/accomplishments/daemon/api.py", line 503, in _get_accomplishments_files_list
    lang = config.get("general", "langdefault")
  File "/usr/lib/python2.7/ConfigParser.py", line 340, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'langdefault' in section: 'general'

Failed to load application: No option 'langdefault' in section: 'general'

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/accomplishments_viewer/AccomplishmentsViewerWindow.py", line 290, in run_daemon_timeout
    self.populate_opp_combos()
  File "/usr/lib/python2.7/dist-packages/accomplishments_viewer/AccomplishmentsViewerWindow.py", line 499, in populate_opp_combos
    self._load_accomplishments()
  File "/usr/lib/python2.7/dist-packages/accomplishments_viewer/AccomplishmentsViewerWindow.py", line 631, in _load_accomplishments
    for acc in self.libaccom.get_all_accomplishments_and_status():
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.369 was not provided by any .service files

Thanks for your bug report.
It seems that there is a problem with one of your accomplishments collections you have installed on your system.
What accomplishment collections you have installed? Or maybe have you tried developing your own?
Also, it may be helpful if you provided us the daemon log file, which should be here: ~/.cache/accomplishments/logs/daemon.log

Jono Bacon (jonobacon) wrote :

This looks like your accomplishments collection is too old. Ensure you are running only the 0.1 release packages.

no longer affects: ubuntu-accomplishments-system
Simon Watson (simon-swat) wrote :

I too am seeing this bug. I was running a pre-0.1 version, but thought that was pretty much self contained.

I've tried moving away a lot of the old config files from /home, but still get the error.

Will continue trying to find the precise cause of this.

Could you please confirm if this is still happening in the latest code? Either grab source from trunk branch, or use the daily-builds PPA (package should be in version 0.1+45 or greater, it will build within several hours).

If the crash is still present, please send the error message you are getting (it will be different due to recent changes in code).

Changed in ubuntu-accomplishments-daemon:
status: New → Incomplete
Jono Bacon (jonobacon) wrote :

Chris, is this still happening?

Chris Wayne (cwayne18) wrote :

Nope, no longer happening. I'll mark it as invalid.

Changed in ubuntu-accomplishments-daemon:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers