Update the Ubuntu colour palette to fit the spec

Bug #1248174 reported by Alberto Salvia Novella on 2013-11-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned
One Hundred Papercuts
Low
Unassigned
Ubuntu Accomplishments Daemon
Undecided
Unassigned
Ubuntu Accomplishments Extra Information
Undecided
Unassigned
Ubuntu Accomplishments System
Undecided
Unassigned
Ubuntu Accomplishments Viewer
Undecided
Unassigned
Ubuntu Accomplishments Web Gallery
Undecided
Unassigned
Ubuntu Brand Guidelines website
Undecided
Unassigned
Ubuntu Community Accomplishments
Undecided
Unassigned
Ubuntu Desktop Accomplishments
Undecided
Unassigned
ubuntu-community
Undecided
Unassigned
gimp (Ubuntu)
Low
Unassigned
inkscape (Ubuntu)
Low
Unassigned
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

****************
HOW TO REPRODUCE
****************

1. In Inkscape create a figure colored "Accent Orange", from the "Ubuntu" colour palette.
2. Compare colour with "Ubuntu Orange" in http://design.ubuntu.com/brand/colour-palette.

******************
EXPECTED BEHAVIOUR
******************

- The colour to be the same.

**************
REAL BEHAVIOUR
**************

- The colour is different.
- The colours listed in the palette from Inkscape have no relationship with the ones in design.ubuntu.com.

***********
WORK-AROUND
***********

- To use the colours in http://design.ubuntu.com/brand/colour-palette instead.

****************
RELEVANT DETAILS
****************

- Orange colour is very similar, but not equal. So it's very probable someone use the wrong colour in their designs for Ubuntu.
- In fact, the logo of "Ubuntu" project in Launchpad is affected (https://launchpad.net/ubuntu).
- A demonstrative image is attached to this bug.

**************
TECHNICAL INFO
**************

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: inkscape 0.48.4-1ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
Uname: Linux 3.8.0-25-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Tue Nov 5 13:47:52 2013
InstallationDate: Installed on 2013-05-21 (167 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: inkscape
UpgradeStatus: Upgraded to saucy on 2013-10-18 (18 days ago)

Related branches

Changed in inkscape (Ubuntu):
importance: Undecided → Low
Changed in inkscape (Ubuntu):
milestone: ubuntu-14.04-alpha-1 → none
Changed in inkscape (Ubuntu):
importance: Low → High
summary: - The Ubuntu colour palette is different from the one in design.ubuntu.com
+ The Ubuntu colour palette in Inkscape is different from the one in
+ design.ubuntu.com
description: updated
jazzynico (jazzynico) wrote :

Confirmed with Inkscape 0.48.3.1 and trunk revision 12780.

I guess we still use a deprecated palette.
Should we create a very limited palette with only 6 colors or one with all the tints as described in the tints section (http://design.ubuntu.com/brand/colour-palette#tints)?

Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
jazzynico (jazzynico) on 2013-11-07
Changed in inkscape (Ubuntu):
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
JNH (jordannh) wrote :

I'm sorry, but what would "Accent Orange" be? For the pallete at the bottom the named colors go from "maroon" to "fuchsia" and then are labeled by hex value.

In Saucy, when I mouse-over the colour, its name is displayed.

Daniel Holbach (dholbach) wrote :

How is Ubuntu Community and Ubuntu Accomplishments involved in this bug?

Changed in ubuntu-community:
status: New → Incomplete
JNH (jordannh) wrote :

In case anyone else is confused about "palette," (probably just me) I think what Alberto means is "swatch." In a new Inkscape document go to View -> Swatches. A "swatches" widget will appear. In my inkscape I needed to manually resize the widget (possibly another bug). Click on the left arrow ("<") and select "Ubuntu." Included in the list is a color called "Accent Orange" which is in the middle of the top row of colors.
I wasn't that familiar with Inkscape to know what you meant. Sorry.

@JNH:

Yes, with colour palette I meant "swatch".

@ Daniel Holbach:

Ubuntu Community and Ubuntu Accomplishments logos are using the wrong colour swatch, by mistake.

Daniel Holbach (dholbach) wrote :

What do you mean by "Ubuntu community" here?

@ Daniel Holbach:

By "Ubuntu community" here I mean the "ubuntu-community" project. The Ubuntu logo used as branding for this project is using the outdated swatch, as the rest of projects listed here.

Just look https://launchpadlibrarian.net/155875160/demonstration.png

JNH (jordannh) on 2014-02-11
Changed in inkscape (Ubuntu):
assignee: nobody → JNH (jordannh)
status: Triaged → In Progress

The attachment "inkscape-bug-807861-typo_in_src_widgets_toolbox_cpp_4685.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
su_v (suv-lp) wrote :

The patch from comment #12 has nothing in it to address the issue tracked here (recreate Inkscape's Ubuntu palette (from 2006, see bug #169711) to match a reduced set of screen colors (RGB in hexadecimal format) used in current Ubuntu branding (2013)).

tags: added: patch-rejected-upstream
su_v (suv-lp) wrote :

Sample palette 'Ubuntu Branding' with Screen hex colors (RGB) taken from <http://design.ubuntu.com/brand/colour-palette> (no "tints").

JNH (jordannh) wrote :

Okay, this is more appropriate, I believe.

su_v (suv-lp) on 2014-02-11
tags: removed: patch-rejected-upstream
su_v (suv-lp) wrote :

Sample extended palette 'Ubuntu Branding' with Screen hex colors (RGB) taken from <http://design.ubuntu.com/brand/colour-palette> and tints (in 10% steps only).

Dmitry Shachnev (mitya57) wrote :

The previous patch was rejected upstream, so I would like to see some guarantees that this one won't be. So please get upstream approval before applying it in Ubuntu.

Changed in inkscape (Ubuntu):
importance: High → Low
Daniel Holbach (dholbach) wrote :

Alberto: I'm still not sure where exactly the wrong colour is used. Like in which instance?

@ Daniel Holbach:

I mean the colour used in the Ubuntu logo from the following page: https://launchpad.net/ubuntu-community

Changed in ubuntu-community:
status: Incomplete → New
Brian Murray (brian-murray) wrote :

As we are awaiting upstream approval, I am going to unsubscribe the sponsors team. Please resubscribe them when the change is accepted upstream.

Okay.

jazzynico (jazzynico) wrote :

Sorry for the delay. I seems the Inkscape and Ubuntu teams were waiting for each other...

The patch from comment #16 looks good, but only changes the Accent Orange value. If I understand correctly, the original report is not about one specific color but requests a whole update of the palette file ("The colours listed in the palette from Inkscape have no relationship with the ones in design.ubuntu.com.").

Thus I'd rather use one of the files suggested by ~suv comments #15 and #17.
Could someone from the Ubuntu design team confirm that the current Inkscape palette file is outdated, not the Accent Orange color only? Thanks!

Patch in comment #16:

  - Doesn't update the palette, but just corrects the orange colour.

Palette in comment #17:

  - Base colours follow the specification.
  - Tints seem to be wrong.
  - Palette name could just be "Ubuntu".

Changed in inkscape (Ubuntu):
assignee: JNH (jordannh) → nobody
status: In Progress → Triaged
Changed in ubuntu-accomplishments-daemon:
status: New → Confirmed
Changed in ubuntu-accomplishments-extra-information:
status: New → Confirmed
Changed in ubuntu-accomplishments-system:
status: New → Confirmed
Changed in ubuntu-accomplishments-viewer:
status: New → Confirmed
Changed in ubuntu-accomplishments-web:
status: New → Confirmed
Changed in ubuntu-brand-guidelines:
status: New → Confirmed
Changed in ubuntu-community-accomplishments:
status: New → Confirmed
Changed in ubuntu-desktop-accomplishments:
status: New → Confirmed
Changed in ubuntu-community:
status: New → Confirmed
summary: The Ubuntu colour palette in Inkscape is different from the one in
- design.ubuntu.com
+ design.ubuntu.com, making many logos to be in the wrong colour at this
+ time
jazzynico (jazzynico) on 2014-08-09
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: none → 0.91
status: Triaged → In Progress

Attached is a new version of the palette based on the file posted comment #17 and updated with Alberto's tint calculator (thanks a lot, Alberto!).
Alberto, would you be willing to confirm that the new file is correct and can be committed in Inkscape please?

Changed in inkscape:
assignee: jazzynico (jazzynico) → Alberto Salvia Novella (es20490446e)

Base colours in <http://design.ubuntu.com/wp-content/uploads/ubuntu-colour-tints.png> doesn't follow the specification in <http://design.ubuntu.com/brand/colour-palette>!!!!

I have reported this as a bug, and emailed the administrators about it.

The bug number is bug #1354718.

Please, validate the file :o

Changed in inkscape:
assignee: Alberto Salvia Novella (es20490446e) → nobody
status: In Progress → Confirmed
Changed in gimp (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
summary: - The Ubuntu colour palette in Inkscape is different from the one in
- design.ubuntu.com, making many logos to be in the wrong colour at this
- time
+ Fit the Ubuntu colour palette to the spec
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - Fit the Ubuntu colour palette to the spec
+ Update the Ubuntu colour palette to fit the spec
jazzynico (jazzynico) wrote :

New palette committed in the trunk, revision 13508.
Thanks for your help, Alberto!

Changed in inkscape:
assignee: nobody → Alberto Salvia Novella (es20490446e)
status: Confirmed → Fix Committed
Daniel Holbach (dholbach) wrote :
Changed in ubuntu-community:
status: Confirmed → Fix Released
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: Triaged → Fix Released

How is this an LibreOffice bug? LibreOffice 4.4.2 on Ubuntu ships with a standard.soc palette that has Accent Orange as RGB (decimal) 221,72,20 which is hex #DD4814 as listed on http://design.ubuntu.com/brand/colour-palette

Changed in libreoffice (Ubuntu):
status: Triaged → Incomplete

If all colours in the LibreOffice palette match <http://design.ubuntu.com/brand/colour-palette>, please set the libreoffice package status to "fix released".

Changed in libreoffice (Ubuntu):
status: Incomplete → Triaged

Never mind, I will check it myself right now.

Changed in libreoffice (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
status: Triaged → In Progress
assignee: Alberto Salvia Novella (es20490446e) → nobody
status: In Progress → Fix Released
Changed in inkscape:
assignee: Alberto Salvia Novella (es20490446e) → nobody
Peter Mahnke (peterm-ubuntu) wrote :

marking as invalid for design.ubuntu.com as we have no inkscape pallets, if there is a specific thing to do on this site, please file a new bug referencing this one.

Changed in ubuntu-brand-guidelines:
status: Confirmed → Invalid
To post a comment you must log in.