UBports flashing guide may need to be updated for MX4

Bug #1690803 reported by zubozrout on 2017-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
UBports Image for Meizu MX4
Fix Released
Undecided
Unassigned

Bug Description

Hello,
since there is no way I know of to boot any image flashed via fastboot on MX4 flashing guide now fails. In my case the tool also failed to detect MX4 correctly.

https://wiki.ubports.com/wiki/How-to-flash-existing-ubuntu-touch-devices-with-Ubports-images

Device detection failed:
sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=recovery-arale.img
Device is |MEIZU6595_LWT_L1|
Device MEIZU6595_LWT_L1 not found on server https://system-image.ubports.com/ channel ubports-touch/legacy

Booting recovery failed:
sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=recovery-arale.img --device=arale
-image=recovery-arale.img --device=arale
2017/05/14 18:59:24 Device is |arale|
2017/05/14 18:59:24 Flashing version 1 from ubports-touch/legacy channel and server https://system-image.ubports.com/ to device arale

After which it says it couldn't boot into recovery.

To make it clear I always had issues with my MX4 when I tried to install Ubuntu from scratch - never worked for me to boot recovery via fastboot but it may have just been a unique issue.

So if any of you have MX4 to test this on please do so and share your experience. Thanks :)

NeoTheThird (neothethird) wrote :

If you get this message : `Device is |MEIZU6595_LWT_L1|` you need to also specify `--device=arale` in your first command. You were flashing from android, right? The guide assumes you are using Ubuntu Touch.

You can also use Magic Device Tool for convenience: https://github.com/MariusQuabeck/magic-device-tool

zubozrout (zubozrout) wrote :

Hello,
that's right - I had Android on my MX4 since January and wanted to switch back. That would explain the failed device detection and it is true this seems to be related since it did work before.

However, the failed boot into recovery is a different thing and I don't think it is related to having Android on the phone. I tried the Magic Device Tool but I had the same results with it as it wasn't able to boot the recovery from fastboot. That is why I had to omit the --bootstrap option in order to be able to install both the official and the UBports image.

zubozrout (zubozrout) wrote :

Btw, if I try something as simple as this it fails:

zubozrout@fxxx:~/mx4$ fastboot boot recovery-arale.img
downloading 'boot.img'...
OKAY [ 0.740s]
booting...
FAILED (remote: unknown command)
finished. total time: 0.754s

Which is why (if this can be confirmed) I would like to see the MX4 instructions on the UBports page modified.

Changed in ubports-arale:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers