No apps open after update v.175 (hammerhead rc-proposed)

Bug #1602916 reported by jay on 2016-07-14
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubports-android
Fix Released
Critical
Marius Gripsgard 

Bug Description

After updating from version-174 to version-175 most of the apps will not open. They load for 2 seconds and then go back to home. The only apps that do open are [phone, contacts, external drives, system settings]. Incoming phone calls quickly appear and disappear before the phone even rings or vibrates.

Also tried doing a re-flash with no luck.

Steps To repeat:
Upgrade or perform a fresh device flash to any version > 174 on the rc-proposed - hammerhead channel

jay (jayywolff) on 2016-07-14
description: updated
description: updated
description: updated

Hi,

Thanks for reporting, will look into it immediately.

Changed in ubports-android:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Marius Gripsgard  (mariogrip)
Alberto Serrano (aserranol) wrote :

Hello,
After install version-180 most of the apps will not open yet. They load and then go back to home.

Thank you
Alberto

rc_proposed, apps still not opening. no audio.

Etienne Van Bogaert (r-etienne) wrote :

this affects me as well. Can we provide more information (e.g. log files and more)?

Changed in ubports-android:
status: In Progress → Fix Committed
Joas (joachimkowalewski) wrote :

When can we expect this update to be released?

Joas (joachimkowalewski) wrote :

rc-proposed 210, I still have this problem

r236 still has issue of phone call appearing and disappearing. Also browser won't open.
Any quick fix available for this?

These two issues are the only ones which are preventing from using this software as daily driver.

Nick Gilla (nickgilla) wrote :

A quick fix until resolved is to address the issues with apparmor. I'm working on a laundry list of apparmor tweaks, but here's what I've got that *mostly* fixes the browser:

https://bugs.launchpad.net/ubports-android/+bug/1625832/comments/7

Clearly, *a lot* of such overrides will be needed for other apps. However, web apps like Gmail have similar issues with oxide_helper that are likely addressed in a similar way to what I've done for the browser.

The way to find these errant apparmor profiles is to grep DENIED from /var/log/syslog. Then, just hunt down the appropriate apparmor profiles, create local ones, and/or create a tunables file. See apparmor wiki.

Cheers.

Changed in ubports-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers