sfdisk says "detected Disk Manager - unable to handle that"

Bug #285716 reported by hjkopel on 2008-10-19
14
Affects Status Importance Assigned to Milestone
ubiquity
Invalid
Undecided
Unassigned
grub-installer (Ubuntu)
Medium
Colin Watson

Bug Description

The install of Xubuntu 8.10 Beta does not complete. When I think that it is ready to say something like "installation is complete system will reboot now please remove CD" it goes back to the live cd mode. When I manually reboot I get a "grub>" prompt but can not get back into Xwindows.
My computer is a Dell Dimension 4100

Colin Watson (cjwatson) wrote :

Moving bug to ubiquity package in Ubuntu.

Changed in ubiquity:
status: New → Invalid
Colin Watson (cjwatson) wrote :

We need some log files in order to investigate this bug. Please reproduce this (i.e. run through the installer until it dumps you into the live CD desktop), and then before you reboot start a web browser and attach the files /var/log/syslog and /var/log/partman to this bug report.

Changed in ubiquity:
status: New → Incomplete
hjkopel (hjkopel) wrote :

After I saw the term ubiquity here I remember the notice "ubiquity stopped unexpectedly". However, I will try the install again later today and get the files.

hjkopel (hjkopel) wrote :

I reported a bug off of the installation, "see bug #285716" with the related files by mistake maybe but I'll download the requested here also.

hjkopel (hjkopel) wrote :

here is the file syslog

hjkopel (hjkopel) wrote :

Off of the live CD I tried to re-install grub and got the following error.
"Failed to fetch http://archive ubuntu.com/ubuntu/pool/main/g/grup/grub_0.97-29 ubuntu 36_i386deb" Later I tried it with the eth0 turned of and got the same error.
I just looked and the file is not there.

Colin Watson (cjwatson) on 2009-05-14
affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
Changed in grub-installer (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
summary: - Xubuntu 8.1 install stops
+ sfdisk says "detected Disk Manager - unable to handle that"
Colin Watson (cjwatson) on 2009-05-14
Changed in grub-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.37ubuntu2

---------------
grub-installer (1.37ubuntu2) karmic; urgency=low

  * If sfdisk fails to set the first primary partition we try as active, try
    the other primary partitions rather than failing. Don't fail even if
    none of them can be set as active, since the BIOS may not mind anyway
    (LP: #285716).
  * Use GRUB 2 by default.

 -- Colin Watson <email address hidden> Mon, 08 Jun 2009 22:05:42 +0100

Changed in grub-installer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments