spell checker does not work

Bug #1375800 reported by keesj on 2014-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
UberWriter (moved to github!)
Undecided
Unassigned

Bug Description

Hi,

I am using uberwriter under gnome3 and have a hard time getting the spell checker to work. I tried installing as many spell checkers and languages as possible but somehow I keep getting the

You can not enable the Spell Checker.
'Please install 'hunspell' or 'aspell' dictionarys for your language from the software center.'

message

I now suspect something else must be going on and have the following questions
-1 how do I determine the language uberwriter is using, can this be printed / shown somewhere?
-2 do I need to install a certain python package to make this work?

uberwrikeesj@yoga:~$ apt-cache policy uberwriter
ter:
  Installed: 14.09.06-public
  Candidate: 14.09.06-public
  Version table:
 *** 14.09.06-public 0
        500 http://ppa.launchpad.net/w-vollprecht/ppa/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

env | grep en
LC_PAPER=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_MONETARY=en_GB.UTF-8
LC_NUMERIC=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LANG=en_US.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LANGUAGE=en_US:en
LC_TIME=en_GB.UTF-8
LC_NAME=en_GB.UTF-8

keesj@yoga:~$ dpkg -l | grep spell
ii aspell 0.60.7~20110707-1ubuntu1 amd64 GNU Aspell spell-checker
ii aspell-en 7.1-0-1 all English dictionary for GNU Aspell
ii aspell-nl 1:2.10-1 all Dutch dictionary for Aspell
ii dictionaries-common 1.20.5 all Common utilities for spelling dictionary tools
ii enchant 1.6.0-10ubuntu1 amd64 Wrapper for various spell checker engines (binary programs)
ii hunspell 1.3.2-6ubuntu2 amd64 spell checker and morphological analyzer (program)
ii hunspell-en-ca 1:4.2.1-0ubuntu1 all English_canadian dictionary for hunspell
ii hunspell-en-us 20070829-4ubuntu3 all English_american dictionary for hunspell
ii hunspell-fr 1:5.0.2-1 all French dictionary for hunspell (dependency package)
ii hunspell-fr-classical 1:5.0.2-1 all French dictionary for hunspell (classical version)
ii libaspell15 0.60.7~20110707-1ubuntu1 amd64 GNU Aspell spell-checker runtime library
ii libenchant1c2a:amd64 1.6.0-10ubuntu1 amd64 Wrapper library for various spell checker engines (runtime libs)
ii libgtkspell0 2.0.16-1ubuntu7 amd64 a spell-checking addon for GTK's TextView widget
ii libhunspell-1.3-0:amd64 1.3.2-6ubuntu2 amd64 spell checker and morphological analyzer (shared library)
ii myspell-en-au 2.1-5.4 all English_australian dictionary for myspell
ii myspell-en-gb 1:4.2.1-0ubuntu1 all English_british dictionary for myspell
rc myspell-en-us 1:4.2.1-0ubuntu1 all English_american dictionary for myspell
ii myspell-en-za 1:4.2.1-0ubuntu1 all English_southafrican dictionary for myspell
ii myspell-nl 1:2.10-1 all Dutch dictionary for Hunspell
ii python-gtkspell 2.25.3-13 amd64 Python bindings for the GtkSpell library
ii python-hunspell 0.1-1build2 amd64 Python 2 binding for Hunspell
ii python3-enchant 1.6.5-2build1 all spellchecking library for Python 3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers