pdf generation for Chinese text

Bug #1281389 reported by Finjon Kiang on 2014-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
UberWriter (moved to github!)
Undecided
Unassigned

Bug Description

When generating PDF with Chinese characters, it will return error message:
pandoc: Error producing PDF from TeX source.
! Package inputenc Error: Unicode char \u8:xxx not set up for use with LaTeX.

I must type the following commands manually to generate Chinese pdf:
pandoc -o c.pdf --latex-engine=xelatex -V mainfont='WenQuanYi Micro Hei' test

Would you like to provide an option to set commands behind the button?

Hi Finjon,

I am wondering: If you don't change the font, does it still work (with
XeLaTeX?)

Cheers,

Wolf

2014-02-17 22:22 GMT-05:00 Finjon Kiang <email address hidden>:

> Public bug reported:
>
> When generating PDF with Chinese characters, it will return error message:
> pandoc: Error producing PDF from TeX source.
> ! Package inputenc Error: Unicode char \u8:xxx not set up for use with
> LaTeX.
>
> I must type the following commands manually to generate Chinese pdf:
> pandoc -o c.pdf --latex-engine=xelatex -V mainfont='WenQuanYi Micro Hei'
> test
>
> Would you like to provide an option to set commands behind the button?
>
> ** Affects: uberwriter
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to
> UberWriter.
> https://bugs.launchpad.net/bugs/1281389
>
> Title:
> pdf generation for Chinese text
>
> Status in This is the project for UberWriter:
> New
>
> Bug description:
> When generating PDF with Chinese characters, it will return error
> message:
> pandoc: Error producing PDF from TeX source.
> ! Package inputenc Error: Unicode char \u8:xxx not set up for use with
> LaTeX.
>
> I must type the following commands manually to generate Chinese pdf:
> pandoc -o c.pdf --latex-engine=xelatex -V mainfont='WenQuanYi Micro Hei'
> test
>
> Would you like to provide an option to set commands behind the button?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/uberwriter/+bug/1281389/+subscriptions
>

Finjon Kiang (kiange) wrote :

If I don't specify the font, then the Chinese characters in the generated pdf file are all gone in Document Viewer 3.10.0. But it doesn't have error messages.

The attachment shows the differences of output between two commands:
pandoc -o c.pdf --latex-engine=xelatex test
pandoc -o c2.pdf --latex-engine=xelatex -V mainfont='WenQuanYi Micro Hei' test

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments