no gui visible in unity

Reported by Martin Pool on 2011-06-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
txAWS
Undecided
Clint Byrum
txaws (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

The only UI for aws-status hangs off a gtk StatusIcon, so this package is entirely broken on unity.

Changed in txaws (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in txaws:
status: New → Confirmed
Duncan McGreggor (oubiwann) wrote :

Robert Collins wrote that component, so I've assigned to him.

Changed in txaws:
assignee: nobody → Robert Collins (lifeless)
Robert Collins (lifeless) wrote :

I don't have time to commit to this bug. Also please ask before assigning - I am subscribed so can claim things myself :-)

Changed in txaws:
assignee: Robert Collins (lifeless) → nobody
Clint Byrum (clint-fewbar) wrote :

I've got an experimental appindicator version in the linked branch which seems to work. It drops the status icon support entirely.. not sure if thats important to keep around for a while.

Changed in txaws:
status: Confirmed → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
tags: added: precise rls-mgr-p-tracking

Kate, Clint -- would you guys be interested in a new release of txAWS
for Precise?

If so, when should we create one? (seems like, at the earliest, when
Client's branch gets merged...)

d

On Thu, Mar 22, 2012 at 11:34 PM, Kate Stewart
<email address hidden> wrote:
> ** Tags added: precise rls-mgr-p-tracking
>
> ** Also affects: txaws (Ubuntu Precise)
>   Importance: High
>       Status: Confirmed
>
> --
> You received this bug notification because you are subscribed to txAWS.
> https://bugs.launchpad.net/bugs/802950
>
> Title:
>  no gui visible in unity
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/txaws/+bug/802950/+subscriptions

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package txaws - 0.2-0ubuntu9

---------------
txaws (0.2-0ubuntu9) precise; urgency=low

  * d/patches/aws-status-add-appindicator.patch: Add support for
    appindicator so GUI is visible and useful in Unity. (LP: #802950)
  * d/rules,d/python-txaws.manpages,d/manpages: Generate basic manpages
    using help2man. (LP: #964164)
  * d/aws-status.install: install new basic manpage and add desktop file.
 -- Clint Byrum <email address hidden> Sat, 24 Mar 2012 16:05:26 -0700

Changed in txaws (Ubuntu Precise):
status: Confirmed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Excerpts from Duncan McGreggor's message of Fri Mar 23 04:04:39 UTC 2012:
> Kate, Clint -- would you guys be interested in a new release of txAWS
> for Precise?
>
> If so, when should we create one? (seems like, at the earliest, when
> Client's branch gets merged...)
>

Hi Duncan. I just now noticed that we don't have SSL endpoint certificate
verification in the current release of txaws (0.2). I see that it landed
in trunk a few months ago.

That makes any use of txaws fairly suspect, since you could be talking
to a MITM ec2 proxy that is intercepting your credentials, userdata,
etc. etc.

So yes, I think it would be quite important for us to have that available
for juju. In fact I may just isolate that as a patch for precise if we
can't get all of 0.3 in.

Changed in txaws:
status: In Progress → Fix Committed
Changed in txaws:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers