Pull refresh on twitter scope and view a tweet sometimes leads to loss of text on the coloured button

Bug #1514878 reported by Dave Morley on 2015-11-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Twitter Scope
High
Kyle Nitzsche

Bug Description

STEPS:
1. Install the latest image using --bootstrap
2. Sign in to twitter from the today scope
3. Refresh the scope
4. Tap on a tweet

EXPECTED:
I expect to always see open in twitter on the coloured button (orange on today and blue in twitter scope)

ACTUAL:
At some point the text will go missing

See screenshots

Related branches

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Kyle Nitzsche (knitzsche) wrote :

It seems that after a refresh and then after waiting for a while (minutes), the some of the Preview action button text labels are forgotten.

if you refresh the scope and look at the buttons, the text comes back.

Changed in twitter-scope:
status: New → Confirmed
importance: Undecided → High
Kyle Nitzsche (knitzsche) wrote :

fixed with twitter scope release 2.2

Changed in twitter-scope:
status: Confirmed → Fix Committed
assignee: nobody → Kyle Nitzsche (knitzsche)
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww46-2015
status: New → Fix Committed
Kyle Nitzsche (knitzsche) wrote :

I recommended an immediate publication to the store after OTA8 to get this out (since this issue was discovered too late for OTA8).

Penk Chen (penk) wrote :

Pushed to store and included in custom tarball, mark as fix released.

Changed in twitter-scope:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers