Failure to resolve certain API links since revision 596

Bug #1174312 reported by Richard Wall on 2013-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Twisted Buildbot Configuration
Undecided
Unassigned
pydoctor
Fix Released
Undecided
Unassigned

Bug Description

See https://twistedmatrix.com/trac/ticket/5681#comment:13

mwh fixed the problem in pydoctor:
 * https://bazaar.launchpad.net/~mwhudson/pydoctor/dev/revision/596

But that change also seems to have broken some links within the API docs. Here are the new errors reported since updating pydoctor:
 * https://buildbot.twistedmatrix.com/builders/documentation/builds/3281/steps/api-documentation/logs/new%20pydoctor%20errors

{{{
twisted.internet._sslverify._handleattrhelper: invalid ref to Certificate.hostFromTransport
twisted.internet._sslverify._handleattrhelper: invalid ref to Certificate.peerFromTransport
twisted.internet.ssl.CertificateOptions.__init__: invalid ref to OpenSSL.crypto.X509
twisted.protocols.amp._NoCertificate.options: invalid ref to twisted.internet.ssl.PrivateCertificate.options
twisted.spread.pb.Copyable.getTypeToCopyFor: invalid ref to getTypeToCopy
twisted.spread.pb.Copyable.jellyFor: invalid ref to getTypeToCopyFor
twisted.spread.pb.RemoteCopy: invalid ref to setCopyableState
twisted.spread.pb.Root.rootObject: invalid ref to pb.BrokerFactory
twisted.spread.pb.ViewPoint: invalid ref to remoteMessageReceived
twisted.trial.runner.DestructiveTestSuite.run: invalid ref to TestSuite.run
twisted.trial.unittest.SynchronousTestCase.patch: invalid ref to addCleanup
twisted.trial.unittest.SynchronousTestCase.runTest: invalid ref to run
twisted.trial.unittest.SynchronousTestCase: invalid ref to run
twisted.trial.unittest.TestCase.__init__: invalid ref to SynchronousTestCase.runTest
twisted.trial.unittest.TestCase._runCleanups: invalid ref to addCleanup
twisted.trial.unittest.TestCase._undeprecateReactor: invalid ref to _deprecateReactor
twisted.trial.unittest.TestCase: invalid ref to assertFailure
twisted.web._newclient: invalid ref to Response.deliverBody
twisted.web.client.ResponseDone: invalid ref to Response.deliverBody
twisted.web.guard.DigestCredentialFactory.decode: invalid ref to twisted.cred.digest.DigestedCredentials
twisted.web.template.Tag._clone: invalid ref to Tag.clone
twisted.web.template.Tag.render: invalid ref to twisted.web.template.Element.lookupRenderMethod
twisted.web.template.Tag: invalid ref to twisted.web.template.Element.lookupRenderMethod
twisted.web.template.slot.name: invalid ref to Tag.fillSlots
twisted.web.template.slot: invalid ref to Tag.fillSlots
}}}

Eg https://twistedmatrix.com/documents/current/api/twisted.web.client.ResponseDone.html currently contains a working link to Response.deliverBody, but that link is no longer there when building with trunk pydoctor.

Michael Hudson-Doyle (mwhudson) wrote :

Oops. This is an arguably existing bug uncovered by yesterday's fix: if something is moved by __all__, its descendants' fullName()s are now correct, but the invariant "ob.system.allobjects[ob.fullName()] is ob" was broken because allobjects was not being updated for the descendants of the moved object. Should be simple to fix, let's see...

Michael Hudson-Doyle (mwhudson) wrote :

OK, I've fixed all the genuinely new failures in trunk now. What I mean by that: "twisted.internet.ssl.CertificateOptions.__init__: invalid ref to OpenSSL.crypto.X509" is not actually a new error, but before yesterday's changes it was being reported as "twisted.internet._sslverify.OpenSSLCertificateOptions.__init__:637 invalid ref to OpenSSL.crypto.X509". This probably counts as an improvement...

Changed in pydoctor:
status: New → Fix Committed
Changed in pydoctor:
status: Fix Committed → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers