Spam on main page of LD from identi.ca

Bug #696037 reported by Laura Czajkowski
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
LoCo Team Portal
High
Adnane Belmadiaf
Twidenash
High
Unassigned

Bug Description

There are 2 spam links to porn sites on the main LD page from identi.ca using the locoteams tag

Related branches

Revision history for this message
Laura Czajkowski (czajkowski) wrote :
Adnane Belmadiaf (daker)
Changed in loco-directory:
importance: Undecided → High
status: New → Confirmed
Michael Hall (mhall119)
Changed in twidenash:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Jonathan Carter (jonathan) wrote :

This affects the twidenash script we use on the Edubuntu website as well. Unfortunately we had to temporarily disable the script as a result. Identi.ca should really deal better with spammers. In the meantime it would be nice to have some filtering capability for twidenash.

Adnane Belmadiaf (daker)
Changed in twidenash:
assignee: nobody → Adnane Belmadiaf (daker)
Adnane Belmadiaf (daker)
Changed in twidenash:
status: Confirmed → In Progress
Revision history for this message
Ronnie (ronnie.vd.c) wrote :

The code need to be rewritten for version 2.0 of twidenash

Revision history for this message
Adnane Belmadiaf (daker) wrote :

We should override the sources array to keep only the twitter api.

Changed in twidenash:
assignee: Adnane Belmadiaf (daker) → nobody
Adnane Belmadiaf (daker)
Changed in loco-team-portal:
status: Confirmed → Triaged
Revision history for this message
Greg Grossmeier (greg.grossmeier) wrote :

As long as identi.ca is not removed from the team pages, please.

Revision history for this message
Laura Czajkowski (czajkowski) wrote :

It would be interesting to see how many teams actually use identi.ca, this is the only service which seems to draw such spam on a regular basis and then results in the same bug being reported, it also results in having to find people to remove it which is time and effort. I wonder would our time and effort be better used elsewhere.

Revision history for this message
Greg Grossmeier (greg.grossmeier) wrote :

TL;DR: Dropping identi.ca support would be a net negative for the Michigan LoCo as they experience more spam on twitter than identi.ca.

Here's the thing:

The Michigan LoCo uses identi.ca primarily because we set up a group, which allows us to control spam much more effectively than tags (they can be moderated). We use it more of an announce list as opposed to discussion, but that is neither here nor there.

From our experience, the vast majority of spam showing up on the LD is from twitter, because someone can signup for twitter, blast all of the relevant #ubuntu tags and then be marked a spambot but that still shows up in LD. The same is true of identi.ca, but it happens much less often for managed groups like the Michigan LoCo's.

Groups have all the same feeds (rss, atom, activitystreams, even foaf) as tags thus are no more complicated to support.

Revision history for this message
Laura Czajkowski (czajkowski) wrote :

again I'd be interested to see how many teams use one or the other or both as some people just post to identi.ca via twitter but no other interaction there and I know a lot of teams do that to appease members who prefer identi.ca but there is not much traffic. And given the amount of time it does take to do the cleaning and regular duplicate bugs it is worth looking at.

Revision history for this message
Greg Grossmeier (greg.grossmeier) wrote :

Laura: That response is a sidestep of the issue and my use case.

Example from Michigan:
http://loco.ubuntu.com/teams/ubuntu-michigan

That spam is only from twitter. If we restricted it to only pull in notices from an identi.ca group (which Michigan uses) then our spam problem would be much closer to zero.

Again, this is just Michigan's use case, but it is something to keep in mind as we discuss what features LD supports.

Revision history for this message
Craig Maloney (craig-decafbad) wrote :

I can confirm what Greg is saying: The spam for the Michigan Team's identi.ca is closely monitored by myself and Greg. I am a moderator as well for identi.ca, and the spam problem is quite low.

I'm sure I can't change your mind, but I'd ask that you reconsider.

Adnane Belmadiaf (daker)
Changed in loco-team-portal:
assignee: nobody → Adnane Belmadiaf (daker)
Adnane Belmadiaf (daker)
Changed in loco-team-portal:
milestone: none → 0.3.11
Adnane Belmadiaf (daker)
Changed in loco-team-portal:
status: Triaged → Fix Committed
Adnane Belmadiaf (daker)
Changed in loco-team-portal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments