tripleo-image-elements/elements/tuskar-ui /os-refresh-config /post-configure.d/101-tuskar-ui needs authentication from Keystone

Bug #1387487 reported by Andy Yan on 2014-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Low
Unassigned
tuskar
Low
Unassigned

Bug Description

In initialization of 101-tuskar-ui , line 21:
"COMPUTE_IMAGE_ID=$( glance image-show overcloud-compute | grep id | awk '$2=="id" {print $4}' )"
The command needs authentication from Keystone. But at that point, Keystone doesn't have endpoints, it is not able to authenticate. So the init of Tuskar-ui failed.
The init work of Keystone should be done in " tripleo-incubator/scripts /register-endpoint". Is that right ?

James Polley (tchaypo) wrote :

I've marked this "incomplete" for TripleO, because I think this needs to be handled as a tuskar bug. Please feel free to change that if this does need to be handled as a tripleo bug.

Changed in tripleo:
status: New → Incomplete
importance: Undecided → Low
Andy Yan (yanchao3) wrote :

Yes´╝îI think this needs to be handled as a tuskar bug.

Derek Higgins (derekh) on 2014-12-17
Changed in tripleo:
status: Incomplete → Won't Fix
Andy Yan (yanchao3) wrote :

Can I ask why won't you fix that ?

Ben Nemec (bnemec) wrote :

If the problem is in tuskar, then there isn't anything to fix in tripleo.

Jay Dobies (jdob) wrote :

I don't want to distract from the fact that it needs to be fixed, but I'm not sure why this is a Tuskar issue. It's in the image element that configures the Tuskar UI. If there was a problem with the nova-api image element, we wouldn't file a bug against nova.

James Slagle (james-slagle) wrote :

i believe this does need to be fixed in tripleo-image-elements. Coming up with that fix should probably be done by someone who knows tuskar. If that's not done, then we can probably go back to WontFix on this one for the tripleo bug and leave it at that I guess.

Changed in tripleo:
status: Won't Fix → Confirmed
Changed in tuskar:
importance: Undecided → Low
status: New → Confirmed
Dougal Matthews (d0ugal) on 2016-01-27
Changed in tuskar:
status: Confirmed → Won't Fix
Steven Hardy (shardy) wrote :

We no longer use or support Tuskar, so I'm going to mark this wontfix and post a patch that removes the element

Steven Hardy (shardy) on 2016-05-25
Changed in tripleo:
status: Confirmed → Won't Fix

Reviewed: https://review.openstack.org/320907
Committed: https://git.openstack.org/cgit/openstack/tripleo-image-elements/commit/?id=f18b2979ac3fb366b4385cdc28c025a127372554
Submitter: Jenkins
Branch: master

commit f18b2979ac3fb366b4385cdc28c025a127372554
Author: Steven Hardy <email address hidden>
Date: Wed May 25 12:18:58 2016 +0100

    Remove tuskar-ui element

    We no longer support or actively develop tuskar-ui, so remove this element

    Change-Id: I75ef485528425c580cbe5223b830b83de56f9a45
    Related-Bug: #1387487

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers