TKLBAM not restoring symlinks properly

Reported by Jeremy Davis on 2012-01-01
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
High
Liraz

Bug Description

Brad Rhoads (bdrhoa) wrote :

This is a blocker! Impossible to turn off a tomcat appliance until this is fixed

Changed in turnkeylinux:
importance: Undecided → High
assignee: nobody → Liraz (liraz-siri)
Liraz (liraz-siri) wrote :

I traced back this issue to an obscure Python bug that effects how shutil.move works when moving symlinks between filesystems:

http://bugs.python.org/issue9993

This only effected tklbam-restore's behavior on small and medium sized EC2 instances (not Micro) since 27/10/2011 when we started mount --bind /tmp to /mnt. Restores to non-EC2 TurnKey installations worked fine. Also, there was never a problem with the backups themselves, just the restore process.

Bottom line: I committed a fix, and we'll push out an automatic update tomorrow so that everyone gets a new version of tklbam automatically. After that restores should work just fine everywhere.

Changed in turnkeylinux:
status: Confirmed → Fix Committed
Jeremy Davis (jedmeister) wrote :

Sounds like it was a tricky one! Good work Liraz!

Liraz (liraz-siri) on 2012-03-01
Changed in turnkeylinux:
status: Fix Committed → Fix Released
Jeremy Davis (jedmeister) wrote :

Looks like the bugfix introduced a regression: https://bugs.launchpad.net/turnkeylinux/+bug/946454

Liraz (liraz-siri) wrote :

It wasn't a regression. More like a dormant bug in mailman being triggered by the turnkey-pylib update. Just goes to show there's no such thing as a totally safe change.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.