TWiki: Can't find/install plugins

Reported by Jeremy Davis on 2010-12-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Medium
Alon Swartz
11.x
Fix Committed
Undecided
Unassigned
12.x
Fix Released
Medium
Alon Swartz

Bug Description

When when clicking on 'find extensions' in the TWiki appliance (v11.0):

Error accessing TWiki.org: Incomplete headers This is most likely because the LWP CPAN module isn't installed.

Reported by gurpal2000 (http://www.turnkeylinux.org/user/24333) on the forums here: http://www.turnkeylinux.org/forum/support/20101022/twiki-upgrading-latest#comment-6338

Partial fix is to install LWP (libwww-perl) Perl module: apt-get install libwww-perl

There is still an issue however (see http://www.turnkeylinux.org/forum/support/20101022/twiki-upgrading-latest#comment-6351). From my research it seems this is caused by a known TWiki bug: http://develop.twiki.org/~twiki4/cgi-bin/view/Bugs/Item6534

The bug report includes a workaround which has been reported to work in TKL:
Workaround until fixed: Remove the -T switch from twiki/bin/configure, e.g. first line should look like this:

#!/usr/bin/perl -w

Changed in turnkeylinux:
importance: Undecided → Medium
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

Thanks for reporting the issue, and providing workarounds. I've committed a fix and will be included in the upcoming release.
To fix currently deployed appliances the following is required:

* Install the missing dependency:
apt-get update
apt-get install libwww-perl

* Workaround insecure dependency checking in configure by removing -T from shebang
sed -i "s|\-wT|-w|" /var/www/twiki/bin/configure

Changed in turnkeylinux:
assignee: nobody → Alon Swartz (alonswartz)
status: Confirmed → Fix Committed
Changed in turnkeylinux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers