moinmoin-2009.10: interwiki links to main MoinMoin wiki broken

Reported by Sergey Vlasov on 2009-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Low
Alon Swartz
2009.10-2-hardy-x86
New
Undecided
Unassigned

Bug Description

In a clean installation of moinmoin-2009.10 interwiki links like MoinMoin:HelpErrata (can be seen on the HelpContents page) do not work - they point to the installed wiki itself instead of http://moinmo.in/ .

Apparently the problem is caused by the wrong setting in /etc/moin/mywiki.py:

    interwikiname = 'MoinMoin'

Changing the interwikiname option value to something different (and not colliding with other InterWiki names) fixes the problem.

Alon Swartz (alonswartz) wrote :

Thanks for reporting this issue.
I have commited the fix and it will be included in all new releases of the MoinMoin appliance.

Changed in turnkeylinux:
status: New → Confirmed
status: Confirmed → Fix Committed
Alon Swartz (alonswartz) wrote :

fix included in 2009.10-2 release

Changed in turnkeylinux:
assignee: nobody → Alon Swartz (alonswartz)
importance: Undecided → Low
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers