phpmyadmin advanced features (pmadb) should be configured by default

Reported by Alon Swartz on 2009-09-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Low
Alon Swartz
2009.10-hardy-x86
New
Undecided
Unassigned

Bug Description

Posted by cpeper on the forums [1] and in the bug tracker [2].
This is a "fork" of [2] as it was opened on a different issue and since then marked as invalid.

pmadb refers to the phpMyAdmin Linked Tables Infrastructure [3].
pmadb provides features suchs as bookmarks, comments, SQL history, relations, PDF schema, and MIME transformation.
Comments and relation view are implemented natively in the newer versions of MySQL, so phpMyAdmin will use the MySQL features when available.

Enabling pmadb requires a controluser to be created (manually), creation of the pamdb using an sql script (located in a different location to documentation due to debian packaging (DPM), giving the controluser the required privilages, and updating the phpmyadmin configuration.

Seeing as the process is not very straight forward for a novice user, it should be pre-configured in TurnKey appliances.

[1] http://www.turnkeylinux.org/forum/support/20090617/phpmyadminconfiguration-broken-pmadb-missing
[2] https://bugs.launchpad.net/turnkeylinux/+bug/388951
[3] http://wiki.phpmyadmin.net/pma/pmadb

Alon Swartz (alonswartz) on 2009-09-08
Changed in turnkeylinux:
status: New → Confirmed
assignee: nobody → Alon Swartz (alonswartz)
importance: Undecided → Low
Alon Swartz (alonswartz) wrote :

This issue has been fixed and will be included in all appliance releases from now onwards (where phpmyadmin is installed)

Changed in turnkeylinux:
status: Confirmed → Fix Committed
Alon Swartz (alonswartz) on 2009-11-01
Changed in turnkeylinux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers