mysql password defined during setup does not work

Reported by homer15 on 2009-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Medium
Alon Swartz
2009.10-hardy-x86
New
Undecided
Unassigned

Bug Description

 i just did a quick test with all the mysql appliances i have.

turnkey-lamp-2009.02-hardy-x86.iso
turnkey-mediawiki-2009.03-hardy-x86.iso
turnkey-phpbb-2009.03-hardy-x86.iso
turnkey-wordpress-2009.03-hardy-x86.iso

i installed all of these from the boot menu. with a simple password of "turnkey" it works fine. with a complex password like "p@$Sw0rD", it allows me to login to webmin but it says "Login failed : Incorrect administration username or password" for accessing the mysql server module.

to fix this, i have to alter the password via the command line and flush the permissions.

Alon Swartz (alonswartz) wrote :

As Liraz mentioned on the forums [1]: "the SQL update command is being passed through to the mysql cli command through the shell, which interpolates certain characters in the password as a variable name"

Changed in turnkeylinux:
assignee: nobody → Alon Swartz (alonswartz)
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

This issue has been fixed, not only for mysql passwords but all passwords specified during installation.
It will be included in all appliances released from now on.

With regards to the fix recommended in the forum post, commands.mkarg() is already being used in all system commands, but was not taking effect on the passwords in certain queries (ie. mysql) due to the nested ' and " required to build the query.

The fix is to escape special characters in the password provided.

Changed in turnkeylinux:
status: Confirmed → Fix Committed
Alon Swartz (alonswartz) on 2009-09-09
summary: - mysql password is defined during setup does not work
+ mysql password defined during setup does not work
Changed in turnkeylinux:
importance: Undecided → Medium
Alon Swartz (alonswartz) on 2009-11-01
Changed in turnkeylinux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers