Not enough PHP memory in TurnKey MediaWiki

Reported by Terry Bondy on 2009-04-13
2
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Undecided
Alon Swartz
2009.10-hardy-x86
New
Undecided
Unassigned

Bug Description

When going to index.php/Special:AllMessages (that's System messages link from the Special Pages page accessible from the link in the left-hand navigation pane)

I get the following on the page:

System messages

Fatal error: Allowed memory size of 20971520 bytes exhausted (tried to allocate 1607681 bytes) in /usr/share/mediawiki/includes/SkinTemplate.php on line 1060

Alon Swartz (alonswartz) wrote :

In general, we have increased the default maximum memory limit on all LAMP (php) appliances to a generous 32MB.
That should be ample, but you could increase it or tweak other configurations in /etc/php5/apache2/php.ini

My guess is the machine might be running low on memory...
  - Are you running the appliance in a VM?
  - How much memory have you allocated the system?
  - Are you running in Live demo mode?

Hi Alon,

Thanks for your reply. To answer your questions:
  - Are you running the appliance in a VM? - Yes, and it is the only VM running, hosted under Sun's VirtualBox.
  - How much memory have you allocated the system? - 512 MB on a 4 GB host. Should there be a recommendation on http://www.turnkeylinux.org/docs/mediawiki?
  - Are you running in Live demo mode? - No.

Regards,
Terry

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Alon Swartz
Sent: April 15, 2009 3:33 PM
To: Terry Bondy
Subject: [Bug 360606] Re: Not enough PHP memory in TurnKey MediaWiki

In general, we have increased the default maximum memory limit on all LAMP (php) appliances to a generous 32MB.
That should be ample, but you could increase it or tweak other configurations in /etc/php5/apache2/php.ini

My guess is the machine might be running low on memory...
  - Are you running the appliance in a VM?
  - How much memory have you allocated the system?
  - Are you running in Live demo mode?

--
Not enough PHP memory in TurnKey MediaWiki
https://bugs.launchpad.net/bugs/360606
You received this bug notification because you are a direct subscriber
of the bug.

Status in TurnKey Linux: New

Bug description:
When going to index.php/Special:AllMessages (that's System messages link from the Special Pages page accessible from the link in the left-hand navigation pane)

I get the following on the page:

System messages

Fatal error: Allowed memory size of 20971520 bytes exhausted (tried to allocate 1607681 bytes) in /usr/share/mediawiki/includes/SkinTemplate.php on line 1060

Alon Swartz (alonswartz) wrote :

I just confirmed the issue, thanks for reporting it.
Simply increasing the php memory limit doesn't solve the issue, so it must be deeper than that.

I'll post a solution/workaround when I find it...

Changed in turnkeylinux:
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

Due to the inclusion of popular extensions by default, the php memory limit is reached when rendering All System Messages with HTML output. When rendering PHP or XML output, this error is not triggered (eg. http://appliance_ip/index.php?title=Special:AllMessages&ot=php)

Fix: Increase mediawiki's php memory_limit to match the server configured limit:
  /etc/mediawiki/LocalSettings.php
  ini_set( 'memory_limit' , '20M' ); --> ini_set( 'memory_limit' , '32M' );

This fix will be included in all TurnKey MediaWiki appliances from now on.

Changed in turnkeylinux:
assignee: nobody → alonswartz
status: Confirmed → Fix Committed
Terry Bondy (terry-bondy) wrote :

Making the change to /etc/mediawiki/LocalSettings.php here confirmed fixed this for already installed applicance.

Thanks.

Kramer (andrew-leifer) wrote :

Same problem, same solution. This is for an already installed appliance P4, 512MB Ram no virtual machine. I gave php 100MB of memory.

Thanks.

Alon Swartz (alonswartz) on 2009-11-01
Changed in turnkeylinux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers