rails: apache not proxying requests to mongrel cluster

Reported by Alon Swartz on 2009-03-26
2
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
High
Alon Swartz

Bug Description

The Apache2 RewriteCond context is supported in the server config, virtual host, directory and .htaccess. The rewrite rules which are meant to proxy requests to the mongrel_cluster were defined outside of the above mentioned context's, which resulted in them not taking effect.

This issue did not arise during testing, as the test case rails application (tracks-1.6) had a fall back rewrite rule for .cgi in its .htaccess, so the application was being served directly from apache.

While testing Rails 2009.03 pre-release with our new test case rails application (tracks-1.7), the bug showed itself due to the fall back rewrite rule being changed to .fcgi (which apache isn't configured to support).

Alon Swartz (alonswartz) wrote :

The fix will be included in very-soon to be released Rails 2009.03

Changed in turnkeylinux:
assignee: nobody → alonswartz
importance: Undecided → High
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

Fix included in the Rails 2009.03 released: http://www.turnkeylinux.org/appliances/rails

Changed in turnkeylinux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers