mediawiki 2009.02: phpmyadmin cannot load mcrypt extension

Reported by Alon Swartz on 2009-03-19
4
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Medium
Alon Swartz
2009.10-hardy-x86
New
Undecided
Unassigned

Bug Description

I just installed the MediaWki appliance. It seems to be running fine, but when I go to phpMyAdmin and login, I get an error message in a yellow box that says "Cannont load mycrypt extension. Please check your php confitguration." Is this normal? I didn't see anything about it looking around the documentation, but maybe I was going too fast...

Thanks--

Al

Alon Swartz (alonswartz) wrote :

Thanks for reporting this, it seems to be a bug in the mediawiki 2009.02 release.
I'll look into what caused it, but in the meantime here is a simple fix:

echo "extension=mcrypt.so" >> /etc/php5/apache2/php.ini
/etc/init.d/apache2 restart

Changed in turnkeylinux:
assignee: nobody → alonswartz
importance: Undecided → Medium
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

Fix commited to development version, will be included in upcoming release.

Changed in turnkeylinux:
status: Confirmed → Fix Committed
Alon Swartz (alonswartz) on 2009-11-01
Changed in turnkeylinux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions