Partition editor seems to be missing options (manual partitioning scheme)

Reported by Alon Swartz on 2008-11-23
2
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
High
Alon Swartz
2009.02-hardy-x86
New
Undecided
Unassigned

Bug Description

(submitted in the forums by volkswagner: http://www.turnkeylinux.org/forum/support/20081122/partition-editor-seems-be-missing-options)

I am trying to install the MediaWiki version. I wanted to do a manual partition scheme.

The partition editor seems to be missing options. When ever I select an existing parition, it won't allow me to edit the partition. I always get the same erro, "no root file system selected".

In past installs of various Ubuntu versions I recall more choices during the partition editor. Normally I can choose mount point, create partition, delete, etc.

Is Turnkey only set up to use the entire disk? No manual paritioning allowed?

The only choices during manual parition setup are:

    * Guided Partioning
    * Help

    * Undo changes to partitions
    * Finish partitioning and write changes to disk

Alon Swartz (alonswartz) on 2008-12-01
Changed in turnkeylinux:
assignee: nobody → alonswartz
importance: Undecided → High
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

This issue has been solved (finally! took me ages to track down the bug), and a fix commited to the turnkeylinux code repository and package archive.
Version: di-live-0.9+1+gnae130b

The fix will be included in all new appliances, and current appliances can update using APT.

For those interested, the bug was due to IFS issues.
    - the user choice (e.g. partition) would not match up internally with the available choices so the choice key could not be returned.
    - by default it would return the RET itself, which would result in a plugin error.
    - the plugin error would result in ask_user returning a failed exitcode
    - which in turn would result in a "No root filesystem" message.

    - bottom line: whitespaces

Changed in turnkeylinux:
status: Confirmed → Fix Committed
Alon Swartz (alonswartz) wrote :

included in all appliances in latest release: 2009.02

Changed in turnkeylinux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers