Joomla upload error

Reported by Alon Swartz on 2008-09-11
6
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Medium
Alon Swartz
2008.10.17-hardy-x86
New
Undecided
Unassigned

Bug Description

(submitted in the forums: http://www.turnkeylinux.org/node/42)

This is the error that is displayed when attempting to Upload a new extension, template or module...
Warning! Failed to move file.

Similar errors:
  - http://pvibeesh.wordpress.com/2007/10/16/joomla-15rc3-warning-failed-to-move-file/
  - http://www.saibharadwaj.com/blog/?p=24

Alon Swartz (alonswartz) on 2008-09-11
description: updated
Alon Swartz (alonswartz) on 2008-09-19
Changed in turnkeylinux:
assignee: nobody → alonswartz
importance: Undecided → Medium
status: New → Confirmed
Alon Swartz (alonswartz) wrote :

This issue has been solved in the upcoming release.

If you are using the current release and would like to fix it, follow these steps:
- login as root, password turnkey
- chown www-data: /var/lib/joomla15/tmp
- chown www-data: /usr/share/joomla15/modules
- chown www-data: /usr/share/joomla15/templates
- chown www-data: /usr/share/joomla15/plugins
- chown www-data: /usr/share/joomla15/language

Unfortunately this is the best fix I could find according to the Joomla documentation.
If anyone is aware of a better, or a way to install user extentions in a different location than core, please post a comment here.

Changed in turnkeylinux:
status: Confirmed → Fix Committed
Alon Swartz (alonswartz) on 2008-10-19
Changed in turnkeylinux:
status: Fix Committed → Fix Released
shooter (sharpshooterofky) wrote :

I tried this..but it didn't work for me.

Is there supposed to be username given after chown
and before www-data??

New to Joomla..please advise

Alon Swartz (alonswartz) wrote :

The fix is to give www-data ownership (owner+group) of the folders.

Forgive my shorthand of not specifying the group, its implied...
$ man chown
    chown [OPTION]... [OWNER][:[GROUP]] FILE...
    If a colon but no group name follows the user name, that user is
    made the owner of the files and the group of the files is changed to
    that user's login group.

It might of been clearer if I had explicitly specified the group ownership, such as:
    - chown www-data:www-data /var/lib/joomla15/tmp
    - chown www-data:www-data /usr/share/joomla15/modules
    - chown www-data:www-data /usr/share/joomla15/templates
    - chown www-data:www-data /usr/share/joomla15/plugins
    - chown www-data:www-data /usr/share/joomla15/language

 Thank You....I'm sorry I'm still very, very green when it comes to
Joomla..

I did type those commands in eXactly as you showed, and they came
back with another prompt, no errors though, ...so did it actually work
and I didn't know it? If I wasn't in the right directory..would those commands work as typed?

Sorry...thanks again for your help..

  -------------- Original message from Alon Swartz <email address hidden>: --------------

> The fix is to give www-data ownership (owner+group) of the folders.
>
> Forgive my shorthand of not specifying the group, its implied...
> $ man chown
> chown [OPTION]... [OWNER][:[GROUP]] FILE...
> If a colon but no group name follows the user name, that user is
> made the owner of the files and the group of the files is changed to
> that user's login group.
> It might of been clearer if I had explicitly specified the group ownership, such
> as:
> - chown www-data:www-data /var/lib/joomla15/tmp
> - chown www-data:www-data /usr/share/joomla15/modules
> - chown www-data:www-data /usr/share/joomla15/templates
> - chown www-data:www-data /usr/share/joomla15/plugins
> - chown www-data:www-data /usr/share/joomla15/language
>
> --
> Joomla upload error
> https://bugs.launchpad.net/bugs/269109
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Turnkey Linux: Fix Released
> Status in Turnkey Linux Series: 2008.10.17-hardy-x86: New
>
> Bug description:
> (submitted in the forums: http://www.turnkeylinux.org/node/42)
>
> This is the error that is displayed when attempting to Upload a new extension,
> template or module...
> Warning! Failed to move file.
>
> Similar errors:
> -
> http://pvibeesh.wordpress.com/2007/10/16/joomla-15rc3-warning-failed-to-move-fil
> e/
> - http://www.saibharadwaj.com/blog/?p=24

Alon Swartz (alonswartz) wrote :

To answer your question, the paths in the commands above are absolute, so they will work no matter your current working directory.

When you attempt to upload a new extension / module / template in the joomla administrative interface, are you getting an error?
If so, what is the error?

FYI - this bugfix has been incorporated in the latest TurnKey Joomla release (turnkey-joomla-2008.10.17-hardy-x86), aswell as other fixes/changes (http://www.turnkeylinux.org/appliances/joomla/releasenotes).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers