AssertionError in pre-receive hook

Bug #1868935 reported by Tom Wardill on 2020-03-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
turnip
High
Thiago F. Pappacena

Bug Description

Occasionally a git import on launchpad fails with something along the lines of:
2020-03-24 14:58:24 INFO Everything up-to-date
2020-03-24 15:05:56 INFO remote: Traceback (most recent call last):
2020-03-24 15:05:56 INFO remote: File "hooks/pre-receive", line 148, in <module>
2020-03-24 15:05:56 INFO remote: rule_lines = check_ref_permissions(sock, rpc_key, ref_paths)
2020-03-24 15:05:56 INFO remote: File "hooks/pre-receive", line 130, in check_ref_permissions
2020-03-24 15:05:56 INFO remote: {'key': rpc_key, 'paths': ref_paths})
2020-03-24 15:05:56 INFO remote: File "hooks/pre-receive", line 120, in rpc_invoke
2020-03-24 15:05:56 INFO remote: res = json.loads(netstring_recv(sock))
2020-03-24 15:05:56 INFO remote: File "hooks/pre-receive", line 104, in netstring_recv
2020-03-24 15:05:56 INFO remote: assert c.isdigit()
2020-03-24 15:05:56 INFO remote: AssertionError

(from http://launchpadlibrarian.net/470506969/registry-systemd-+git-systemd.log)

Not sure what the cause is.

Related branches

Tom Wardill (twom) on 2020-03-25
summary: - AssertionError in pre-recieve hook
+ AssertionError in pre-receive hook
Changed in turnip:
importance: Undecided → High
Andy Whitcroft (apw) wrote :

bug 1880756 likely relates to this. Triggered by large numbers of refs in a push.

Colin Watson (cjwatson) on 2020-05-28
Changed in turnip:
status: New → Triaged
Changed in turnip:
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

The AssertionError in the pre-receive hook is fixed now, although the systemd import now fails differently (https://launchpadlibrarian.net/483804127/registry-systemd-+git-systemd.log). https://code.launchpad.net/~cjwatson/launchpad/+git/launchpad/+merge/373732 may be related.

Changed in turnip:
assignee: nobody → Thiago F. Pappacena (pappacena)
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers