hide main window from unity launcher

Bug #902939 reported by Brandon Williams on 2011-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tunnel Manager
Low
Brandon Williams

Bug Description

When "iconify to status tray" is enabled, there should be no little triangle next to the icon on the unity launcher if the main window is not visible.

When minToTray is enabled, destroy the window on close/iconify instead of simply calling iconify. Whenever deiconify is called, check whether there's a mainWindow to deiconify and if not, create it.

I'm not getting an event trigger when I click the iconify button. Still gotta figure that out.

Matt Zuba (matt-mattzuba) wrote :

Wondering if there has been any progress on this... I love this tunnel manager far more than gSTM, but this is probably the only bug that is 'bugging' me

Thanks for the feedback. I wasn't sure that there was anyone else who is as bothered by this as I am.

I have figured out how to handle this for all cases where the application receives a notification of some sort. This includes both clicking the close button and clicking the status tray icon. Unity is not delivering the expected window-state-change notification when the window is iconified, though, so it's still wrong when the minimize button is clicked.

I had hoped to fix this in its entirety in one bug, but since someone other than me is bothered by this aesthetic oddity, I'll plan to release a fix for this soon.

Changed in tunnelmanager:
status: Confirmed → Fix Committed

I committed a fix (revision 70) for this.

Clicking the status tray icon or the close button will completely hide the application from the launcher. I can't figure out how to get a minimize notification from unity, or even how to determine that the window is minimized, so I can't hide the app from the launcher on minimize. Still, when minimized, hidden by other windows, or otherwise out-of-focus, the main window will be presented to the user if the status icon is clicked.

I haven't yet verified whether the new code is working under window managers that correctly handle the minimize button. I'll try to remember to do that soon.

summary: - hide main window from unity launch
+ hide main window from unity launcher

Works as expected on lucid with lxde (including correct handling of minimize, in this case).

Changed in tunnelmanager:
status: Fix Committed → Fix Released
Matt Zuba (matt-mattzuba) wrote :

I believe the way you have it now is semantically correct... and other applications appear to behave this way as well (Pidgin, for example). And it is what I would expect... if I minimize, I would expect that it remain in the launcher. If I close, I would expect that it leave the launcher. If I close and it has a systray icon, I would expect the systray icon to remain (unless there was an option otherwise).

Thanks for the fix!

Thanks for the verification!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers