per port naming

Bug #594602 reported by E.Panepucci on 2010-06-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tunnel Manager
Wishlist
Brandon Williams

Bug Description

It would be nice to have a property called "local_name" for each port so it can referenced by name.

My case is that I am using tunnelmanager to maintain tunnels for 3 networks, each behind a different gateway but all with similarly named computers. So I start tunnels for all 3 networks and then I need to remember which local_port to use for each computer in all 3 networks.

If for each port I can assign a *local_name* then I can have a script which parses the XML and builds the corresponding ssh command to execute. I have actually done this, i.e., edited the file defaults.xml and added this extra property. Tunnelmanager doesn't choke on reading the file but of course it won't keep the attribute if I save the file from within the GUI so for the time being I just edit the file by hand.

With my script I can then do:

    lsh zac@6sc1 (zac @ console1 on network "6S")

or
   lsh zac@10sc1 (zac @ console1 on network "10S")

Cheers,
   Zac

I'm reluctant to add functionality at this particular point in time if it will require new translations. I want to get a non-beta release out this summer some time that has as much complete translation work as possible.

I will look into adding this without any new translatable text.

Changed in tunnelmanager:
importance: Undecided → Wishlist
Changed in tunnelmanager:
milestone: none → 0.7.3
Changed in tunnelmanager:
status: New → Confirmed
assignee: nobody → Brandon Williams (opensource-subakutty)

1. Modify the glade file to add a new non-required name field in the port entry dialog.

2. Modify the tunnel dialog and the main dialog to include the the name in the list view and tree view.

3. Modify tunnelmanager_cli to output the name for each port, if present.

4. Modify PortInfo.py to save and restore name fields.

testing today!
All the best,
   Zac

On Tue, Aug 24, 2010 at 11:20 PM, Brandon Williams
<email address hidden> wrote:
> 1. Modify the glade file to add a new non-required name field in the
> port entry dialog.
>
> 2. Modify the tunnel dialog and the main dialog to include the the name
> in the list view and tree view.
>
> 3. Modify tunnelmanager_cli to output the name for each port, if
> present.
>
> 4. Modify PortInfo.py to save and restore name fields.
>
> --
> per port naming
> https://bugs.launchpad.net/bugs/594602
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SSH Tunnel Manager: Confirmed
>
> Bug description:
> It would be nice to have a property called "local_name" for each port so it can referenced by name.
>
> My case is that I am using tunnelmanager to maintain tunnels for 3 networks, each behind a different gateway but all with similarly named computers. So I start tunnels for all 3 networks and then I need to remember which local_port to use for each computer in all 3 networks.
>
> If for each port I can assign a *local_name* then I can have a script which parses the XML and builds the corresponding ssh command to execute. I have actually done this, i.e., edited the file defaults.xml and added this extra property. Tunnelmanager doesn't choke on reading the file but of course it won't keep the attribute if I save the file from within the GUI so for the time being I just edit the file by hand.
>
> With my script I can then do:
>
>    lsh zac@6sc1  (zac @ console1 on network "6S")
>
> or
>   lsh zac@10sc1  (zac @ console1 on network "10S")
>
> Cheers,
>   Zac
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/tunnelmanager/+bug/594602/+subscribe
>

I haven't submitted changes for this yet. I was just mapping out the items required for implementation.

I'll change that status to 'committed' when the changes are complete and submitted.

Changed in tunnelmanager:
status: Confirmed → Fix Committed

OK ... now I just committed fixes for the bugs targeted against version 0.7.3. I haven't uploaded the new version to my PPA yet, though, and version 0.7.3 isn't technically "released" yet, because I'd like to give you a chance to test the new version.

The port name field isn't required, and there's no code to guarantee that it will be a unique identifier within the specification for an individual tunnel. However, you can add a name via both the GUI and CLI utilities, and you can view the name in all places where the port specification is listed.

I uploaded a new tarball and a new ubuntu package. Just click on the milestone name above to see the links.

Changed in tunnelmanager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers