unity indicator since ubuntu 14.04 no longer displayed

Bug #1395667 reported by Martin Bruns on 2014-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tunnel Manager
Critical
Brandon Williams

Bug Description

Hi,

since the upgrade to ubuntu 14.10 the unity indicator is no longer shown.

The application seems to run but I have no access to any GUI.

Kind Regards
Martin

Apologies for the delay in responding. I may not be able to look into this for a few weeks. My most up to date install at the moment is 14.04. I will install a 14.10 chroot over the winter holidays to reproduce the problem and find a fix.

Changed in tunnelmanager:
status: New → Confirmed

Even in my 14.04 chroot the tunnelmanager app indicator will not display. I get the same behavior that I see in my new 14.10 chroot.

As a work around for now, open ~/.TunnelManager/properties.conf and change these settings:

showicon = True
mintotray = True
launchintray = True

to these:

showicon = False
mintotray = False
launchintray = False

This should allow the main editor gui to show up again, and also prevent the app from attempting to minimize to the try. Until I figure out how to fix this, I'm afraid it will be necessary to run with the gui window exposed and use it for tunnel management.

summary: - unity indicator since ubuntu 14.10 no longer displayed
+ unity indicator since ubuntu 14.04 no longer displayed
Changed in tunnelmanager:
assignee: nobody → Brandon Williams (opensource-subakutty)
importance: Undecided → Critical

Really, all you need is to add:

[GUI]
showicon = False

The other settings can remain as they are, and the settings below [DEFAULT] can be left alone too.

This turned out to be much more simple than I thought. Since trusty (at least), python-appindicator is no longer installed as part of the default environment. I will add it as a recommended package and also change the default settings to not minimize to the system tray so that if the icon doesn't appear at all (unity without python-appindicator or some other environment with no system tray) you will have to make an explicit config change to make the GUI hide itself. I will leave figuring out why it doesn't know that it's not showing up in the systray for a separate bug.

For now, simply "sudo apt-get python-appindicator" and the unity indicator will start showing up again.

Fix commited in revision 79.

Changed in tunnelmanager:
status: Confirmed → Fix Committed

Fix released in package version 0.7.7.4-0ubuntu1.

Changed in tunnelmanager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers